aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 21 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 7e9a52b6..80dffb87 100644
--- a/configure.ac
+++ b/configure.ac
@@ -358,10 +358,26 @@ AC_DEFINE_DIR([PACKAGE_DATA], [datarootdir], [The directory for installing read-
358packagesrcdir=`cd $srcdir && pwd` 358packagesrcdir=`cd $srcdir && pwd`
359AC_DEFINE_UNQUOTED(PACKAGE_SOURCE_DIR, "${packagesrcdir}", [source dir]) 359AC_DEFINE_UNQUOTED(PACKAGE_SOURCE_DIR, "${packagesrcdir}", [source dir])
360 360
361AC_SUBST(GNUNET_FS_GTK_NAME, $PACKAGE_NAME, [name of the program]) 361AC_SUBST(GNUNET_FS_GTK_NAME, "GNUnet-FS-GTK", [name of the program])
362AC_SUBST(GNUNET_PEERINFO_GTK_NAME, "GNUnet-Peerinfo-GTK", [name of the program])
363AC_SUBST(GNUNET_STATISTICS_GTK_NAME, "GNUnet-Statistics-GTK", [name of the program])
364AC_SUBST(GNUNET_SETUP_GTK_NAME, "GNUnet-Setup", [name of the program])
365
362AC_SUBST(GNUNET_FS_GTK_VERSION3, $PACKAGE_VERSION, [version of the program]) 366AC_SUBST(GNUNET_FS_GTK_VERSION3, $PACKAGE_VERSION, [version of the program])
367AC_SUBST(GNUNET_PEERINFO_GTK_VERSION3, $PACKAGE_VERSION, [version of the program])
368AC_SUBST(GNUNET_STATISTICS_GTK_VERSION3, $PACKAGE_VERSION, [version of the program])
369AC_SUBST(GNUNET_SETUP_GTK_VERSION3, $PACKAGE_VERSION, [version of the program])
370
363AC_SUBST(GNUNET_FS_GTK_YEARFROM, [2010], [year of the first release]) 371AC_SUBST(GNUNET_FS_GTK_YEARFROM, [2010], [year of the first release])
364AC_SUBST(GNUNET_FS_GTK_YEARTO, [$(date | sed -e 's/.* \([[[:digit:]]]\+\)$/\1/')], [year of the most current release]) 372AC_SUBST(GNUNET_PEERINFO_GTK_YEARFROM, [2010], [year of the first release])
373AC_SUBST(GNUNET_STATISTICS_GTK_YEARFROM, [2010], [year of the first release])
374AC_SUBST(GNUNET_SETUP_GTK_YEARFROM, [2010], [year of the first release])
375
376thisyear=$(date | sed -e 's/.* \([[[:digit:]]]\+\)$/\1/')
377AC_SUBST(GNUNET_FS_GTK_YEARTO, ${thisyear}, [year of the most current release])
378AC_SUBST(GNUNET_PEERINFO_GTK_YEARTO, ${thisyear}, [year of the most current release])
379AC_SUBST(GNUNET_STATISTICS_GTK_YEARTO, ${thisyear}, [year of the most current release])
380AC_SUBST(GNUNET_SETUP_GTK_YEARTO, ${thisyear}, [year of the most current release])
365 381
366AC_OUTPUT([ 382AC_OUTPUT([
367Makefile 383Makefile
@@ -380,4 +396,7 @@ po/Makefile
380gnunet-fs-gtk.desktop 396gnunet-fs-gtk.desktop
381gnunet-setup.desktop 397gnunet-setup.desktop
382contrib/gnunet_fs_gtk_about_window.glade 398contrib/gnunet_fs_gtk_about_window.glade
399contrib/gnunet_peerinfo_gtk_about_window.glade
400contrib/gnunet_statistics_gtk_about_window.glade
401contrib/gnunet_setup_about_window.glade
383]) 402])