aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 76111ed5..83203a8a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -392,7 +392,7 @@ AC_ARG_WITH(gnunet,
392 EXT_LIB_PATH="-L${lookin}/lib64 $EXT_LIB_PATH" 392 EXT_LIB_PATH="-L${lookin}/lib64 $EXT_LIB_PATH"
393 fi 393 fi
394 ] 394 ]
395 ),,[#include <gnunet/platform.h>] 395 ),,
396 ) 396 )
397 ] 397 ]
398) 398)
@@ -422,14 +422,14 @@ AS_IF([test "x$gnunet" = "x0" -a ! "x$lookin" = "x"],
422 fi 422 fi
423 423
424 ] 424 ]
425 ),,[#include <gnunet/platform.h>] 425 ),,
426 ) 426 )
427 AC_CHECK_HEADERS([gnunet/gnunet_conversation_service.h], 427 AC_CHECK_HEADERS([gnunet/gnunet_conversation_service.h],
428 AC_CHECK_LIB([gnunetspeaker], [GNUNET_SPEAKER_destroy], 428 AC_CHECK_LIB([gnunetspeaker], [GNUNET_SPEAKER_destroy],
429 [ 429 [
430 gnunet_conversation=1 430 gnunet_conversation=1
431 ] 431 ]
432 ),,[#include <gnunet/platform.h>] 432 ),,
433 ) 433 )
434 LIBS="$backup_LIBS" 434 LIBS="$backup_LIBS"
435 CFLAGS="$backup_CFLAGS" 435 CFLAGS="$backup_CFLAGS"
@@ -447,7 +447,7 @@ AM_CONDITIONAL(HAVE_CONVERSATION, test x$gnunet_conversation != x0)
447backup_CPPFLAGS="$CPPFLAGS" 447backup_CPPFLAGS="$CPPFLAGS"
448CPPFLAGS="$GNUNET_CPPFLAGS $backup_CPPFLAGS" 448CPPFLAGS="$GNUNET_CPPFLAGS $backup_CPPFLAGS"
449AC_CHECK_HEADERS([gnunet/gnunet_fs_service.h gnunet/gnunet_statistics_service.h gnunet/gnunet_core_service.h], [], 449AC_CHECK_HEADERS([gnunet/gnunet_fs_service.h gnunet/gnunet_statistics_service.h gnunet/gnunet_core_service.h], [],
450 AC_MSG_ERROR([compiling gnunet-gtk requires GNUnet core headers]), [#include <gnunet/platform.h>]) 450 AC_MSG_ERROR([compiling gnunet-gtk requires GNUnet core headers]),)
451CPPFLAGS="$backup_CPPFLAGS" 451CPPFLAGS="$backup_CPPFLAGS"
452 452
453SAVELIBS=$LIBS 453SAVELIBS=$LIBS