aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 12 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index bf2ae65c..26130f0a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -246,7 +246,7 @@ AC_ARG_WITH(gtk_version,
246 ], 246 ],
247 [AC_MSG_RESULT([--with-gtk-version not specified])]) 247 [AC_MSG_RESULT([--with-gtk-version not specified])])
248 248
249without_gtk=false 249without_gtk=true
250if test "x$check_for_3" != "xfalse" 250if test "x$check_for_3" != "xfalse"
251then 251then
252 AM_PATH_GTK_3_0([$check_for_3],without_gtk=false,) 252 AM_PATH_GTK_3_0([$check_for_3],without_gtk=false,)
@@ -258,7 +258,7 @@ then
258 fi 258 fi
259fi 259fi
260 260
261if test "x$without_gtk" == "xfalse" -a "x$check_for_2" != "xfalse" 261if test "x$without_gtk" == "xtrue" -a "x$check_for_2" != "xfalse"
262then 262then
263 AM_PATH_GTK_2_0([$check_for_2],without_gtk=false,) 263 AM_PATH_GTK_2_0([$check_for_2],without_gtk=false,)
264 # test for libunique 264 # test for libunique
@@ -324,17 +324,17 @@ then
324 backup_CPPFLAGS="$CPPFLAGS" 324 backup_CPPFLAGS="$CPPFLAGS"
325 if test "x$check_for_2" != "xfalse" 325 if test "x$check_for_2" != "xfalse"
326 then 326 then
327 GLADE_LIBS="-L${lookin}/lib" 327 GLADE_LIBS="-L${lookin}/lib"
328 GLADE_CFLAGS="-I${lookin}/include/libgladeui-1.0" 328 GLADE_CFLAGS="-I${lookin}/include/libgladeui-1.0"
329 GLADE_CPPFLAGS="-I${lookin}/include/libgladeui-1.0" 329 GLADE_CPPFLAGS="-I${lookin}/include/libgladeui-1.0"
330 LIBS="$GLADE_LIBS $backup_LIBS" 330 LIBS="$GLADE_LIBS $backup_LIBS"
331 CFLAGS="$GLADE_CFLAGS $backup_CFLAGS" 331 CFLAGS="$GLADE_CFLAGS $backup_CFLAGS"
332 CPPFLAGS="$GLADE_CPPFLAGS $backup_CPPFLAGS" 332 CPPFLAGS="$GLADE_CPPFLAGS $backup_CPPFLAGS"
333 AC_CHECK_HEADERS([glib.h gmodule.h gtk/gtk.h gdk/gdk.h gdk/gdkpixbuf.h gladeui/glade.h], 333 AC_CHECK_HEADERS([glib.h gmodule.h gtk/gtk.h gdk/gdk.h gdk/gdkpixbuf.h gladeui/glade.h],
334 AC_CHECK_LIB([gladeui-1], [glade_xml_node_new], 334 AC_CHECK_LIB([gladeui-1], [glade_xml_node_new],
335 [glade=1] 335 [glade=1]
336 )
336 ) 337 )
337 )
338 fi 338 fi
339 if test "x$glade" == "x0" 339 if test "x$glade" == "x0"
340 then 340 then