aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 12 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 1b33e28c..5f184603 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,5 @@
1# This file is part of GNUnet. 1# This file is part of GNUnet.
2# (C) 2001--2011 Christian Grothoff (and other contributing authors) 2# (C) 2001--2012 Christian Grothoff (and other contributing authors)
3# 3#
4# GNUnet is free software; you can redistribute it and/or modify 4# GNUnet is free software; you can redistribute it and/or modify
5# it under the terms of the GNU General Public License as published 5# it under the terms of the GNU General Public License as published
@@ -117,7 +117,7 @@ AM_GNU_GETTEXT([external])
117 117
118AC_CHECK_HEADERS([errno.h stdio.h unistd.h locale.h sys/stat.h sys/types.h langinfo.h libintl.h unistd.h stddef.h argz.h sys/socket.h netinet/in.h stdarg.h]) 118AC_CHECK_HEADERS([errno.h stdio.h unistd.h locale.h sys/stat.h sys/types.h langinfo.h libintl.h unistd.h stddef.h argz.h sys/socket.h netinet/in.h stdarg.h])
119 119
120GNUNET_FS_APP="fs" 120GNUNET_FS_APP=""
121AC_ARG_ENABLE([fs-app], 121AC_ARG_ENABLE([fs-app],
122 AS_HELP_STRING([--disable-fs-app],[Do not build gnunet-fs-gtk application])) 122 AS_HELP_STRING([--disable-fs-app],[Do not build gnunet-fs-gtk application]))
123AS_IF([test "x$enable_fs_app" != "xno"], [ 123AS_IF([test "x$enable_fs_app" != "xno"], [
@@ -125,6 +125,14 @@ AS_IF([test "x$enable_fs_app" != "xno"], [
125]) 125])
126AC_SUBST(GNUNET_FS_APP) 126AC_SUBST(GNUNET_FS_APP)
127 127
128GNUNET_GNS_APP=""
129AC_ARG_ENABLE([gns-app],
130 AS_HELP_STRING([--disable-gns-app],[Do not build gnunet-gns-gtk application]))
131AS_IF([test "x$enable_gns_app" != "xno"], [
132 GNUNET_FS_APP="gns"
133])
134AC_SUBST(GNUNET_FS_APP)
135
128GNUNET_SETUP_APP="" 136GNUNET_SETUP_APP=""
129AC_ARG_ENABLE([setup-app], 137AC_ARG_ENABLE([setup-app],
130 AS_HELP_STRING([--disable-setup-app],[Do not build gnunet-setup application])) 138 AS_HELP_STRING([--disable-setup-app],[Do not build gnunet-setup application]))
@@ -392,6 +400,7 @@ AC_DEFINE_DIR([PACKAGE_DATA], [datarootdir], [The directory for installing read-
392packagesrcdir=`cd $srcdir && pwd` 400packagesrcdir=`cd $srcdir && pwd`
393AC_DEFINE_UNQUOTED(PACKAGE_SOURCE_DIR, "${packagesrcdir}", [source dir]) 401AC_DEFINE_UNQUOTED(PACKAGE_SOURCE_DIR, "${packagesrcdir}", [source dir])
394 402
403AC_SUBST(GNUNET_GNS_GTK_NAME, "GNUnet-GNS-GTK", [name of the program])
395AC_SUBST(GNUNET_FS_GTK_NAME, "GNUnet-FS-GTK", [name of the program]) 404AC_SUBST(GNUNET_FS_GTK_NAME, "GNUnet-FS-GTK", [name of the program])
396AC_SUBST(GNUNET_PEERINFO_GTK_NAME, "GNUnet-Peerinfo-GTK", [name of the program]) 405AC_SUBST(GNUNET_PEERINFO_GTK_NAME, "GNUnet-Peerinfo-GTK", [name of the program])
397AC_SUBST(GNUNET_STATISTICS_GTK_NAME, "GNUnet-Statistics-GTK", [name of the program]) 406AC_SUBST(GNUNET_STATISTICS_GTK_NAME, "GNUnet-Statistics-GTK", [name of the program])
@@ -421,6 +430,7 @@ src/Makefile
421src/include/Makefile 430src/include/Makefile
422src/lib/Makefile 431src/lib/Makefile
423src/fs/Makefile 432src/fs/Makefile
433src/gns/Makefile
424src/peerinfo/Makefile 434src/peerinfo/Makefile
425src/setup/Makefile 435src/setup/Makefile
426src/statistics/Makefile 436src/statistics/Makefile