diff options
Diffstat (limited to 'libltdl/Makefile.am')
-rw-r--r-- | libltdl/Makefile.am | 51 |
1 files changed, 0 insertions, 51 deletions
diff --git a/libltdl/Makefile.am b/libltdl/Makefile.am deleted file mode 100644 index 9b560285..00000000 --- a/libltdl/Makefile.am +++ /dev/null | |||
@@ -1,51 +0,0 @@ | |||
1 | ## Process this file with automake to produce Makefile.in | ||
2 | |||
3 | AUTOMAKE_OPTIONS = no-dependencies foreign | ||
4 | |||
5 | if INSTALL_LTDL | ||
6 | include_HEADERS = ltdl.h | ||
7 | lib_LTLIBRARIES = libltdl.la | ||
8 | else | ||
9 | noinst_HEADERS = ltdl.h | ||
10 | endif | ||
11 | |||
12 | if CONVENIENCE_LTDL | ||
13 | noinst_LTLIBRARIES = libltdlc.la | ||
14 | endif | ||
15 | |||
16 | ## Make sure these will be cleaned even when they're not built by | ||
17 | ## default. | ||
18 | CLEANFILES = libltdl.la libltdlc.la | ||
19 | |||
20 | libltdl_la_SOURCES = ltdl.c | ||
21 | libltdl_la_LDFLAGS = -no-undefined -version-info 4:0:1 | ||
22 | libltdl_la_LIBADD = $(LIBADD_DL) | ||
23 | |||
24 | libltdlc_la_SOURCES = ltdl.c | ||
25 | libltdlc_la_LIBADD = $(LIBADD_DL) | ||
26 | |||
27 | ## Because we do not have automatic dependency tracking: | ||
28 | ltdl.lo: ltdl.h config.h | ||
29 | |||
30 | $(libltdl_la_OBJECTS) $(libltdlc_la_OBJECTS): libtool | ||
31 | libtool: $(LIBTOOL_DEPS) | ||
32 | $(SHELL) ./config.status --recheck | ||
33 | |||
34 | ## This allows us to install libltdl without using ln and without creating | ||
35 | ## a world writeable directory. | ||
36 | ## FIXME: Remove this rule once automake can do this properly by itself. | ||
37 | local-install-files: $(DISTFILES) | ||
38 | -rm -rf $(DESTDIR)$(datadir)/libtool/libltdl | ||
39 | $(mkinstalldirs) $(DESTDIR)$(datadir)/libtool/libltdl | ||
40 | @for file in $(DISTFILES); do \ | ||
41 | case $$file in \ | ||
42 | $(srcdir)/*) file=`echo "$$file" | sed "s|^$(srcdir)/||"`;; \ | ||
43 | esac; \ | ||
44 | d=$(srcdir); \ | ||
45 | if test -d $$d/$$file; then \ | ||
46 | cp -r $$d/$$file $(DESTDIR)$(datadir)/libtool/libltdl/$$file; \ | ||
47 | else \ | ||
48 | test -f $(DESTDIR)$(datadir)/libtool/libltdl/$$file \ | ||
49 | || cp $$d/$$file $(DESTDIR)$(datadir)/libtool/libltdl/$$file || :; \ | ||
50 | fi; \ | ||
51 | done | ||