aboutsummaryrefslogtreecommitdiff
path: root/src/conversation/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/conversation/Makefile.am')
-rw-r--r--src/conversation/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/src/conversation/Makefile.am b/src/conversation/Makefile.am
new file mode 100644
index 00000000..ef5fa5c0
--- /dev/null
+++ b/src/conversation/Makefile.am
@@ -0,0 +1,23 @@
1SUBDIRS = .
2
3INCLUDES = \
4 -I$(top_srcdir)/ \
5 -I$(top_srcdir)/src/include \
6 @GTK_CFLAGS@ \
7 @GNUNET_CFLAGS@ \
8 @GLADE_CFLAGS@
9
10bin_PROGRAMS = gnunet-conversation-gtk
11
12gnunet_conversation_gtk_SOURCES = \
13 gnunet-conversation-gtk.c \
14 gnunet-conversation-gtk_about.c
15
16gnunet_conversation_gtk_LDADD = \
17 $(top_builddir)/src/lib/libgnunetgtk.la \
18 @GTK_LIBS@ \
19 @GLADE_LIBS@ @GNUNET_LIBS@ \
20 -lgnunetutil -lgnunetidentity -lgnunetconversation -lgnunetspeaker -lgnunetmicrophone -lgnunetgns -lgnunetfs -lextractor \
21 $(INTLLIBS)
22gnunet_conversation_gtk_LDFLAGS = \
23 -export-dynamic