aboutsummaryrefslogtreecommitdiff
path: root/src/plugins/chat/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/chat/Makefile.am')
-rw-r--r--src/plugins/chat/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/src/plugins/chat/Makefile.am b/src/plugins/chat/Makefile.am
new file mode 100644
index 00000000..c6979fab
--- /dev/null
+++ b/src/plugins/chat/Makefile.am
@@ -0,0 +1,18 @@
1INCLUDES = \
2 -I$(top_srcdir)/intl \
3 -I$(top_srcdir)/src/include \
4 @GTK_CFLAGS@ \
5 @GNUNETGTK_CFLAGS@
6
7plugindir = $(libdir)/GNUnet
8
9plugin_LTLIBRARIES = \
10 libgnunetgtkmodule_chat.la
11
12libgnunetgtkmodule_chat_la_SOURCES = \
13 chat.c
14libgnunetgtkmodule_chat_la_LIBADD = \
15 $(top_builddir)/src/common/libgnunetgtk_common.la \
16 -lgnunetutil @GTK_LIBS@ @GNUNETGTK_LIBS@
17libgnunetgtkmodule_chat_la_LDFLAGS = \
18 -export-dynamic -avoid-version -module