aboutsummaryrefslogtreecommitdiff
path: root/src/social/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/social/Makefile.am')
-rw-r--r--src/social/Makefile.am23
1 files changed, 12 insertions, 11 deletions
diff --git a/src/social/Makefile.am b/src/social/Makefile.am
index 94a9ba1..bb125a8 100644
--- a/src/social/Makefile.am
+++ b/src/social/Makefile.am
@@ -1,5 +1,6 @@
1# This Makefile.am is in the public domain 1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include 2AM_CPPFLAGS = -I$(top_srcdir)/src/include \
3 $(GNUNET_CPPFLAGS)
3 4
4pkgcfgdir= $(pkgdatadir)/config.d/ 5pkgcfgdir= $(pkgdatadir)/config.d/
5 6
@@ -23,7 +24,7 @@ lib_LTLIBRARIES = libgnunetsocial.la
23libgnunetsocial_la_SOURCES = \ 24libgnunetsocial_la_SOURCES = \
24 social_api.c social.h 25 social_api.c social.h
25libgnunetsocial_la_LIBADD = \ 26libgnunetsocial_la_LIBADD = \
26 $(top_builddir)/src/util/libgnunetutil.la \ 27 -lgnunetutil \
27 $(top_builddir)/src/psycutil/libgnunetpsycutil.la \ 28 $(top_builddir)/src/psycutil/libgnunetpsycutil.la \
28 $(GN_LIBINTL) $(XLIB) 29 $(GN_LIBINTL) $(XLIB)
29libgnunetsocial_la_LDFLAGS = \ 30libgnunetsocial_la_LDFLAGS = \
@@ -41,18 +42,18 @@ gnunet_social_SOURCES = \
41gnunet_social_LDADD = \ 42gnunet_social_LDADD = \
42 libgnunetsocial.la \ 43 libgnunetsocial.la \
43 $(top_builddir)/src/psycutil/libgnunetpsycutil.la \ 44 $(top_builddir)/src/psycutil/libgnunetpsycutil.la \
44 $(top_builddir)/src/util/libgnunetutil.la 45 -lgnunetutil
45 46
46gnunet_service_social_SOURCES = \ 47gnunet_service_social_SOURCES = \
47 gnunet-service-social.c 48 gnunet-service-social.c
48gnunet_service_social_LDADD = \ 49gnunet_service_social_LDADD = \
49 $(top_builddir)/src/util/libgnunetutil.la \ 50 -lgnunetutil \
50 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 51 -lgnunetstatistics \
51 $(top_builddir)/src/psycutil/libgnunetpsycutil.la \ 52 $(top_builddir)/src/psycutil/libgnunetpsycutil.la \
52 $(top_builddir)/src/psyc/libgnunetpsyc.la \ 53 $(top_builddir)/src/psyc/libgnunetpsyc.la \
53 $(top_builddir)/src/identity/libgnunetidentity.la \ 54 -lgnunetidentity \
54 $(top_builddir)/src/gns/libgnunetgns.la \ 55 -lgnunetgns \
55 $(top_builddir)/src/namestore/libgnunetnamestore.la \ 56 -lgnunetnamestore \
56 $(GN_LIBINTL) 57 $(GN_LIBINTL)
57 58
58 59
@@ -70,10 +71,10 @@ test_social_SOURCES = \
70 test_social.c 71 test_social.c
71test_social_LDADD = \ 72test_social_LDADD = \
72 libgnunetsocial.la \ 73 libgnunetsocial.la \
73 $(top_builddir)/src/testing/libgnunettesting.la \ 74 -lgnunettesting \
74 $(top_builddir)/src/util/libgnunetutil.la \ 75 -lgnunetutil \
75 $(top_builddir)/src/psycutil/libgnunetpsycutil.la \ 76 $(top_builddir)/src/psycutil/libgnunetpsycutil.la \
76 $(top_builddir)/src/identity/libgnunetidentity.la 77 -lgnunetidentity
77 78
78EXTRA_DIST = \ 79EXTRA_DIST = \
79 test_social.conf 80 test_social.conf