summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schanzenbach <schanzen@gnunet.org>2022-04-04 19:44:45 +0200
committerMartin Schanzenbach <schanzen@gnunet.org>2022-04-04 19:44:45 +0200
commitaa3b3f27f1dfa5fa970b468a1b797ae42809c134 (patch)
treea650ca05f387a02bf7ba568e062370de9bb1533c
parent60e93b8f0dd03c30d652b0fa665e4cd15b234f0f (diff)
BUILD: Simplify mhd detection
-rw-r--r--configure.ac11
1 files changed, 2 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 43d112572..8f74d5749 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1028,19 +1028,12 @@ CPPFLAGS="$SAVE_CPPFLAGS"
AC_ARG_WITH([microhttpd],
[AS_HELP_STRING([--with-microhttpd=PFX],
[base of libmicrohttpd installation])],
- [httpd=${withval}],
- [httpd=check])
-
-AS_CASE([$withval],
- [no],
- [AC_MSG_ERROR([GNUnet requires libmicrohttpd >= 0.9.63])],
- [yes],
- [PKG_CHECK_MODULES([MHD], [libmicrohttpd >= 0.9.63], [libmhd=1], [libmhd=0])],
[SAVE_PKG_PATH="$PKG_CONFIG_PATH"
PKG_CONFIG_PATH="$httpd/lib/pkgconfig"
export PKG_CONFIG_PATH
PKG_CHECK_MODULES([MHD], [libmicrohttpd >= 0.9.63], [libmhd=1], [libmhd=0])
- PKG_CONFIG_PATH="$SAVE_PKG_PATH"])
+ PKG_CONFIG_PATH="$SAVE_PKG_PATH"],
+ [PKG_CHECK_MODULES([MHD], [libmicrohttpd >= 0.9.63], [libmhd=1], [libmhd=0])])
AS_IF([test "x$libmhd" = "x0"],
[AC_MSG_ERROR([GNUnet requires libmicrohttpd >= 0.9.63])])