summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schanzenbach <mschanzenbach@posteo.de>2021-04-26 10:28:24 +0200
committerMartin Schanzenbach <mschanzenbach@posteo.de>2021-04-26 10:28:24 +0200
commiteeff7e335b56ce14dd6bc04136b0eee223cf6363 (patch)
treec0e2c8c868bcb941cff328e1096bdaf6719f8e15
parent87def80f115a05314b2ff25b9ed53a8112a5490f (diff)
-towards #6851: autotools 2.70
-rw-r--r--configure.ac23
-rw-r--r--po/POTFILES.in2
-rw-r--r--src/include/platform.h8
3 files changed, 9 insertions, 24 deletions
diff --git a/configure.ac b/configure.ac
index 4a2f148ff..b82a72fec 100644
--- a/configure.ac
+++ b/configure.ac
@@ -19,9 +19,9 @@
# Process this file with autoconf to produce a configure script.
#
#
-AC_PREREQ(2.61)
+AC_PREREQ([2.71])
# Checks for programs.
-AC_INIT([gnunet], [0.14.1], [bug-gnunet@gnu.org])
+AC_INIT([gnunet],[0.14.1],[bug-gnunet@gnu.org])
AC_CONFIG_AUX_DIR([build-aux])
# check for legacy option that is no longer supported (#5627) and fail hard
@@ -35,14 +35,13 @@ AC_ARG_WITH(nssdir,
AC_CANONICAL_TARGET
AC_CANONICAL_HOST
-AC_CANONICAL_SYSTEM
AM_INIT_AUTOMAKE
m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])], [AM_DEFAULT_VERBOSITY=1 AC_SUBST(AM_DEFAULT_VERBOSITY)])
AC_CONFIG_HEADERS([gnunet_config.h])
AH_TOP([#define _GNU_SOURCE 1])
AC_CONFIG_MACRO_DIR([m4])
AC_PROG_AWK
-AC_PROG_CC_C99
+AC_PROG_CC
AC_PROG_OBJC
AC_PROG_INSTALL
AC_PROG_LN_S
@@ -416,16 +415,7 @@ gcrypt=0
NEED_LIBGCRYPT_API=1
NEED_LIBGCRYPT_VERSION=1.6.0
-# Check if we have libgcrypt >= 1.9. Some things do not work with it
-gcrypt19=0
-AM_PATH_LIBGCRYPT("$NEED_LIBGCRYPT_API:1.9.0",
- [AC_MSG_WARN(["Some subsystems do not work with gcrypt >=1.9.0"])
- gcrypt=1
- gcrypt19=1],
- [AM_PATH_LIBGCRYPT("$NEED_LIBGCRYPT_API:$NEED_LIBGCRYPT_VERSION", gcrypt=1)]
-)
-AM_CONDITIONAL(HAVE_NOLIBGCRYPT19,
- [test "$gcrypt19" = 0])
+AM_PATH_LIBGCRYPT("$NEED_LIBGCRYPT_API:$NEED_LIBGCRYPT_VERSION", gcrypt=1)
AC_CHECK_DECLS([gcry_mpi_set_opaque_copy], [], [], [[#include <gcrypt.h>]])
AS_IF([test $gcrypt = 0],
@@ -1323,7 +1313,6 @@ LIBS=$SAVE_LIBS
# Checks for standard header files.
AC_HEADER_DIRENT
-AC_HEADER_STDC
# Check for headers that are ALWAYS required
AC_CHECK_HEADERS([fcntl.h math.h errno.h ctype.h limits.h stdio.h stdlib.h string.h unistd.h stdarg.h signal.h locale.h sys/stat.h sys/types.h],,AC_MSG_ERROR([Compiling GNUnet requires standard UNIX headers files: fcntl.h math.h errno.h ctype.h limits.h stdio.h stdlib.h string.h unistd.h stdarg.h signal.h locale.h sys/stat.h sys/types.h]))
@@ -1544,7 +1533,8 @@ AM_GNU_GETTEXT_VERSION([0.18.1])
AC_TYPE_PID_T
AC_TYPE_SIZE_T
AC_TYPE_MODE_T
-AC_HEADER_TIME
+AC_CHECK_HEADERS_ONCE([sys/time.h])
+
AC_HEADER_STAT
AC_HEADER_STDBOOL
AC_STRUCT_TM
@@ -1580,7 +1570,6 @@ AC_FUNC_MEMCMP
AC_FUNC_SELECT_ARGTYPES
AC_FUNC_CHOWN
-AC_TYPE_SIGNAL
AC_FUNC_STAT
AC_FUNC_STRFTIME
AC_FUNC_VPRINTF
diff --git a/po/POTFILES.in b/po/POTFILES.in
index dd36b7411..36f5e7734 100644
--- a/po/POTFILES.in
+++ b/po/POTFILES.in
@@ -313,6 +313,7 @@ src/reclaim/plugin_rest_reclaim.c
src/reclaim/reclaim_api.c
src/reclaim/reclaim_attribute.c
src/reclaim/reclaim_credential.c
+src/reclaim/test.c
src/regex/gnunet-daemon-regexprofiler.c
src/regex/gnunet-regex-profiler.c
src/regex/gnunet-regex-simulation-profiler.c
@@ -497,6 +498,7 @@ src/util/bandwidth.c
src/util/benchmark.c
src/util/bio.c
src/util/buffer.c
+src/util/child_management.c
src/util/client.c
src/util/common_allocation.c
src/util/common_endian.c
diff --git a/src/include/platform.h b/src/include/platform.h
index 355bf0051..32bb637f1 100644
--- a/src/include/platform.h
+++ b/src/include/platform.h
@@ -109,16 +109,10 @@
#if HAVE_SYS_PARAM_H
#include <sys/param.h>
#endif
-#if TIME_WITH_SYS_TIME
-#include <sys/time.h>
-#include <time.h>
-#else
#if HAVE_SYS_TIME_H
#include <sys/time.h>
-#else
-#include <time.h>
-#endif
#endif
+#include <time.h>
#ifdef BSD
#include <net/if.h>
#endif