aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorng0 <ng0@n0.is>2019-03-04 13:51:57 +0000
committerng0 <ng0@n0.is>2019-03-04 13:51:57 +0000
commit77b135454da98206cc216b81d1afe57f57a6e1da (patch)
tree6bb2c3389ab01f93e0923c11c9f767ae4d70df83 /Makefile.am
parentd4cea440095e8447e89daef039fdf8f251f2663d (diff)
downloadgnunet-77b135454da98206cc216b81d1afe57f57a6e1da.tar.gz
gnunet-77b135454da98206cc216b81d1afe57f57a6e1da.zip
Add rule to run lint-python script
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 9be41951e..41d366b93 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -34,3 +34,7 @@ check-bashism:
34 printf "Run checkbashism on all .sh files.\n" 34 printf "Run checkbashism on all .sh files.\n"
35 printf "Currently this expects checkbashism.pl at a fixed location." 35 printf "Currently this expects checkbashism.pl at a fixed location."
36 find . -type f ! -path '*/.*' ! -path '*/_*' -name '*.sh' -print0 | xargs -0 ~/src/scripts/src/checkbashisms.pl -f 36 find . -type f ! -path '*/.*' ! -path '*/_*' -name '*.sh' -print0 | xargs -0 ~/src/scripts/src/checkbashisms.pl -f
37
38check-python:
39 printf "Running flake8 and 2to3 if detected.\n"
40 $(top_srcdir)/contrib/scripts/lint-python.sh