aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorng0 <ng0@n0.is>2019-10-14 14:52:33 +0000
committerng0 <ng0@n0.is>2019-10-14 14:52:33 +0000
commit3d968d36122b64b374feb1be0fd131f6691995f0 (patch)
tree564aee614f9f8de45a43a41e07909598fdfed5b2 /Makefile.am
parentf801acf4e19dd4a6bec3911f81a16d73e5ddbf84 (diff)
downloadgnunet-3d968d36122b64b374feb1be0fd131f6691995f0.tar.gz
gnunet-3d968d36122b64b374feb1be0fd131f6691995f0.zip
add yapf to make pretty
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index e8bd98da1..579939b09 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -39,7 +39,11 @@ doc_DATA = COPYING README
39 39
40ACLOCAL_AMFLAGS = -I m4 40ACLOCAL_AMFLAGS = -I m4
41 41
42# TODO: better nesting.
42if HAVE_UNCRUSTIFY_BINARY 43if HAVE_UNCRUSTIFY_BINARY
43pretty: 44pretty:
44 find $(top_srcdir) -type f -name '*.c' -or -name '*.h' -print0 | xargs -0 uncrustify -c $(top_srcdir)/contrib/uncrustify.cfg --replace --no-backup 2>&1 || true 45 find $(top_srcdir) -type f -name '*.c' -or -name '*.h' -print0 | xargs -0 uncrustify -c $(top_srcdir)/contrib/uncrustify.cfg --replace --no-backup 2>&1 || true
46if HAVE_YAPF_BINARY
47 find $(top_srcdir) -type f -name '*.py' -or -name '*.py.in' -print0 | xargs -0 $(YAPF_BINARY) -i 2>&1 || true
48endif
45endif 49endif