aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorng0 <ng0@n0.is>2019-12-01 23:29:37 +0000
committerng0 <ng0@n0.is>2019-12-01 23:29:37 +0000
commit5a525c0349701d8b511c34ef2deaf0eec7b26f22 (patch)
treead0a0a7224a35db6fca4de6364d44fafb8b6ce3d /Makefile.am
parentdf0af6b7067e6a4ad0a88f2775da28cfc159ee66 (diff)
downloadgnunet-5a525c0349701d8b511c34ef2deaf0eec7b26f22.tar.gz
gnunet-5a525c0349701d8b511c34ef2deaf0eec7b26f22.zip
define HAVE_AWK... we require awk for many parts, but for some cases
it could make sense to skip it.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index edcd28b92..f8725390e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -70,5 +70,7 @@ check-python:
70 printf "Running flake8 and 2to3 if detected.\n" 70 printf "Running flake8 and 2to3 if detected.\n"
71 $(top_srcdir)/contrib/scripts/lint/lint-python.sh || true 71 $(top_srcdir)/contrib/scripts/lint/lint-python.sh || true
72 72
73if HAVE_AWK
73check-texinfo: 74check-texinfo:
74 @cd $(top_srcdir); find . -type f ! -path '*/.*' -name '*.texi' -print0 | xargs -0 ./contrib/scripts/check-texinfo.awk > $(srcdir)/texinfo_lint.log || true 75 @cd $(top_srcdir); find . -type f ! -path '*/.*' -name '*.texi' -print0 | xargs -0 ./contrib/scripts/check-texinfo.awk > $(srcdir)/texinfo_lint.log || true
76endif