aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorng0 <ng0@n0.is>2019-03-06 17:00:50 +0000
committerng0 <ng0@n0.is>2019-03-06 17:00:50 +0000
commitbd7147b59925c3748529d04d7c58042a95821ee0 (patch)
tree5163395d5c9c767d95d88686b1a91e9e1c643c50 /Makefile.am
parenteac5c1681f80ae4f0589d395a3da66fda603e224 (diff)
downloadgnunet-bd7147b59925c3748529d04d7c58042a95821ee0.tar.gz
gnunet-bd7147b59925c3748529d04d7c58042a95821ee0.zip
Fix #5631
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am42
1 files changed, 1 insertions, 41 deletions
diff --git a/Makefile.am b/Makefile.am
index 485ee16fd..abc6f9e42 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,7 +4,7 @@ AM_CPPFLAGS = -I$(top_srcdir)/src/include
4if DOCUMENTATION_ONLY 4if DOCUMENTATION_ONLY
5 SUBDIRS = doc 5 SUBDIRS = doc
6else 6else
7 SUBDIRS = m4 src po pkgconfig 7 SUBDIRS = m4 src po pkgconfig lint
8if DOCUMENTATION 8if DOCUMENTATION
9 SUBDIRS += doc 9 SUBDIRS += doc
10endif 10endif
@@ -27,43 +27,3 @@ docdir = $(datadir)/doc/gnunet/
27doc_DATA = COPYING README 27doc_DATA = COPYING README
28 28
29ACLOCAL_AMFLAGS = -I m4 29ACLOCAL_AMFLAGS = -I m4
30
31# Check for bashisms in shell scripts
32# Very verbose, need to exclude more files.
33check-bashism:
34 printf "Run checkbashism on all .sh files.\n"
35 printf "Currently this expects checkbashism.pl at a fixed location."
36 find . -type f ! -path '*/.*' ! -path '*/_*' -name '*.sh' -print0 | xargs -0 ~/src/scripts/src/checkbashisms.pl -f 2>&1 | tee $(top_srcdir)/bashism.log || true
37
38check-python:
39 printf "Running flake8 and 2to3 if detected.\n"
40 $(top_srcdir)/contrib/scripts/lint-python.sh || true
41
42check-man:
43 printf "Running lint-man.sh in doc/man.\n"
44 @cd $(top_srcdir)/doc/man ; $(top_srcdir)/../../contrib/scripts/lint-man.sh || true
45
46check-texinfo:
47 printf "Running basic texinfo linters\n"
48 # exception to add: ignore license files.
49 # exception to add: uref's can go above 79 chars.
50 printf "...line length over 79 chars?\n" 2>&1 | tee $(top_srcdir)/doc/handbook/texinfo_handbook.log || true
51 @cd $(top_srcdir)/doc/handbook ; find . -type f ! -path '*/.*' -name '*.texi' -print0 | xargs -0 awk 'length>79 {print FILENAME":"NR":"$$0}' > $(top_srcdir)/texinfo_handbook.log || true
52 printf "...line length over 79 chars?\n" 2>&1 | tee $(top_srcdir)/doc/tutorial/texinfo_tutorial.log || true
53 @cd $(top_srcdir)/doc/tutorial ; find . -type f ! -path '*/.*' -name '*.texi' -print0 | xargs -0 awk 'length>79 {print FILENAME":"NR":"$$0}' > $(top_srcdir)/texinfo_tutorial.log || true
54 printf "...lines containing macros incompatible with old makeinfo?\n" 2>&1 | tee -a $(top_srcdir)/doc/handbook/texinfo_handbook.log || true
55 @cd $(top_srcdir)/doc/handbook ; find . -type f ! -path '*/.*' -name '*.texi' -print0 | xargs -0 awk '/@geq\{\}/ {print FILENAME":"NR":"$$0}' >> $(top_srcdir)/texinfo_handbook.log || true
56 printf "...lines containing macros incompatible with old makeinfo?\n" 2>&1 | tee -a $(top_srcdir)/doc/tutorial/texinfo_tutorial.log || true
57 @cd $(top_srcdir)/doc/tutorial ; find . -type f ! -path '*/.*' -name '*.texi' -print0 | xargs -0 awk '/@geq\{\}/ {print FILENAME":"NR":"$$0}' >> $(top_srcdir)/texinfo_tutorial.log || true
58 printf "...lines containing macros incompatible with texi2mdoc?\n" 2>&1 | tee -a $(top_srcdir)/doc/handbook/texinfo_handbook.log || true
59 @cd $(top_srcdir)/doc/handbook ; find . -type f ! -path '*/.*' -name '*.texi' -print0 | xargs -0 awk '/@footnote\{/ {print FILENAME":"NR":"$$0}' >> $(top_srcdir)/texinfo_handbook.log || true
60 printf "...lines containing macros incompatible with texi2mdoc?\n" 2>&1 | tee -a $(top_srcdir)/doc/tutorial/texinfo_tutorial.log || true
61 @cd $(top_srcdir)/doc/tutorial ; find . -type f ! -path '*/.*' -name '*.texi' -print0 | xargs -0 awk '/@footnote\{/ {print FILENAME":"NR":"$$0}' >> $(top_srcdir)/texinfo_tutorial.log || true
62 printf "...lines telling us what is left TODO or to fix?\n" 2>&1 | tee -a $(top_srcdir)/doc/handbook/texinfo_handbook.log || true
63 @cd $(top_srcdir)/doc/handbook ; find . -type f ! -path '*/.*' -name '*.texi' -print0 | xargs -0 awk '/TODO/ {print FILENAME":"NR":"$$0}' >> $(top_srcdir)/texinfo_handbook.log || true
64 @cd $(top_srcdir)/doc/handbook ; find . -type f ! -path '*/.*' -name '*.texi' -print0 | xargs -0 awk '/XXX/ {print FILENAME":"NR":"$$0}' >> $(top_srcdir)/texinfo_handbook.log || true
65 printf "...lines telling us what is left TODO or to fix?\n" 2>&1 | tee -a $(top_srcdir)/doc/tutorial/texinfo_tutorial.log || true
66 @cd $(top_srcdir)/doc/tutorial ; find . -type f ! -path '*/.*' -name '*.texi' -print0 | xargs -0 awk '/TODO/ {print FILENAME":"NR":"$$0}' >> $(top_srcdir)/texinfo_tutorial.log || true
67 @cd $(top_srcdir)/doc/tutorial ; find . -type f ! -path '*/.*' -name '*.texi' -print0 | xargs -0 awk '/XXX/ {print FILENAME":"NR":"$$0}' >> $(top_srcdir)/texinfo_tutorial.log || true
68
69check-linters: check-bashism check-python check-man check-texinfo