aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorng0 <ng0@n0.is>2019-10-14 12:10:35 +0000
committerng0 <ng0@n0.is>2019-10-14 12:10:35 +0000
commit341fd49b42855e5b197ecfd98bafc66e65eccfa8 (patch)
treecd55c41c5ba54603b8fb82c96a8db651487af53f /Makefile.am
parent6dce2a314c8823fcf0b619f9f447d9ea7126d958 (diff)
downloadgnunet-341fd49b42855e5b197ecfd98bafc66e65eccfa8.tar.gz
gnunet-341fd49b42855e5b197ecfd98bafc66e65eccfa8.zip
'make pretty' rule using uncrustify, detect uncrustify in configure script.
closes #5904
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index d69dd3a82..f2b48b358 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -38,3 +38,8 @@ docdir = $(datadir)/doc/gnunet/
38doc_DATA = COPYING README 38doc_DATA = COPYING README
39 39
40ACLOCAL_AMFLAGS = -I m4 40ACLOCAL_AMFLAGS = -I m4
41
42if HAVE_UNCRUSTIFY
43pretty:
44 find $(top_srcdir) -type f ! -path '*/.*' ! -path '*/_*' -name '*.c' -name '*.h' -print0 | xargs -0 uncrustify -c $(top_srcdir) --replace --no-backup 2>&1 || true
45endif