summaryrefslogtreecommitdiff
path: root/README
diff options
context:
space:
mode:
authorng0 <ng0@n0.is>2019-02-25 01:43:36 +0000
committerng0 <ng0@n0.is>2019-02-25 01:43:36 +0000
commit689614a7e51f4fda776e99aa5892811fa5923b2d (patch)
treec0bdc53331443d599166395b730c2aef02b46335 /README
parentd555400775739277bdc1a093933c3681d3c3566b (diff)
README clarifications
Diffstat (limited to 'README')
-rw-r--r--README45
1 files changed, 25 insertions, 20 deletions
diff --git a/README b/README
index 232a3c61f..5eadcda9f 100644
--- a/README
+++ b/README
@@ -41,7 +41,7 @@ These are the direct dependencies for running GNUnet:
- libidn:
- libidn2 (prefered)
or
- - libidn >= 1.0
+ - libidn >= 1.0
- libextractor >= 0.6.1 (highly recommended)
- openssl >= 1.0 (binary, used to generate X.509 certificate
for gnunet-gns-proxy-setup-ca)
@@ -54,36 +54,36 @@ These are the direct dependencies for running GNUnet:
- Texinfo >= 5.2 [*1]
- makeinfo >= 4.8
- make[*3]
-- which (bootstrap script and some Makefiles)
+- which (some Makefiles)
- gettext
- zlib
These are the dependencies for GNUnet's testsuite:
-- Bash (optional (?), for some tests)
-- python >= 3.7 (optional, only python 3.7 is supported)
-- python-future >= 3.7 (optional, only python 3.7 is supported)
+- Bash (optional (?[*4]), for some tests)
+- python >= 3.7 (only python 3.7 is supported)
+- python-future >= 3.7 (only python 3.7 is supported)
These are the optional dependencies:
-- libopus >= 1.0.1 (optional, for experimental conversation tool)
-- libpulse >= 2.0 (optional, for experimental conversation tool)
-- libogg >= 1.3.0 (optional, for experimental conversation tool)
-- libnss (optional, certtool binary (for convenient installation of GNS proxy))
-- python2.7-future (optional, for gnunet-qr)
-- python-zbar >= 0.10 (optional, for gnunet-qr)
-- TeX Live >= 2012 (optional, for gnunet-bcd[*])
-- texi2mdoc (optional, for automatic mdoc generation [*2])
-- libglpk >= 4.45 (optional, for experimental code)
-- perl5 (optional, for some utilities)
-- guile 1.6.4 (or later up to 1.8?, optional for gnunet-download-manager)
-- python2.7 >= 2.7 (optional, for gnunet-qr, only python 2.7 is supported)
-- bluez (optional, for bluetooth support)
+- libopus >= 1.0.1 (for experimental conversation tool)
+- libpulse >= 2.0 (for experimental conversation tool)
+- libogg >= 1.3.0 (for experimental conversation tool)
+- libnss (certtool binary (for convenient installation of GNS proxy))
+- python2.7-future (for gnunet-qr)
+- python-zbar >= 0.10 (for gnunet-qr)
+- TeX Live >= 2012 (for gnunet-bcd[*])
+- texi2mdoc (for automatic mdoc generation [*2])
+- libglpk >= 4.45 (for experimental code)
+- perl5 (for some utilities)
+- guile 1.6.4 (or later up to 1.8?, for gnunet-download-manager)
+- python2.7 >= 2.7 (for gnunet-qr, only python 2.7 is supported)
+- bluez (for bluetooth support)
- miniupnpc
-- libpbc >= 0.5.14 (optional, for Attribute-Based Encryption and Identity Provider functionality)
-- libgabe (optional, for Attribute-Based Encryption and Identity Provider functionality,
+- libpbc >= 0.5.14 (for Attribute-Based Encryption and Identity Provider functionality)
+- libgabe (for Attribute-Based Encryption and Identity Provider functionality,
from https://github.com/schanzen/libgabe)
Recommended autotools for compiling the Git version are:
@@ -113,6 +113,11 @@ Recommended autotools for compiling the Git version are:
you, open a bug so that we can get a more portable
fix in.
+[*4] We are commited to portable tools and solutions
+ where possible. While the shellscripts work with
+ NetBSD's sh, there's no warranty some bashisms
+ are leftover.
+
Requirements
============