aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorng0 <ng0@n0.is>2019-10-17 14:34:23 +0000
committerng0 <ng0@n0.is>2019-10-17 14:34:23 +0000
commitf497ba4fe3c613c04f02378831f43664dbed6601 (patch)
tree1e91f8cf95479092ec8e31e129cd7da52d5e0f97 /configure.ac
parentc08cc5aeb3b2daa8711c86162575953a271e6b3e (diff)
downloadgnunet-f497ba4fe3c613c04f02378831f43664dbed6601.tar.gz
gnunet-f497ba4fe3c613c04f02378831f43664dbed6601.zip
maybe improve sudo detection.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 13 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index f1c93b309..7e86b6276 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1358,17 +1358,19 @@ AC_SUBST(DATAROOTDIR)
1358 1358
1359# test for sudo 1359# test for sudo
1360AC_MSG_CHECKING(for sudo) 1360AC_MSG_CHECKING(for sudo)
1361AC_ARG_WITH(sudo, 1361AC_CHECK_PROGS(SUDO_BINARY, [sudo], false)
1362 [ --with-sudo=PATH path to sudo binary (or just yes)], 1362AM_CONDITIONAL(HAVE_SUDO, test x$SUDO_BINARY != xfalse)
1363 [AC_MSG_RESULT("$with_sudo") 1363#AC_ARG_WITH(sudo,
1364 AS_CASE([$with_sudo], 1364# [ --with-sudo=PATH path to sudo binary (or just yes)],
1365 [no],[SUDO_BINARY=], 1365# [AC_MSG_RESULT("$with_sudo")
1366 [yes],[SUDO_BINARY=sudo], 1366# AS_CASE([$with_sudo],
1367 [SUDO_BINARY=$with_sudo])], 1367# [no],[SUDO_BINARY=],
1368 [AC_MSG_RESULT([no])]) 1368# [yes],[SUDO_BINARY=sudo],
1369AC_SUBST(SUDO_BINARY) 1369# [SUDO_BINARY=$with_sudo])],
1370AM_CONDITIONAL([HAVE_SUDO], 1370# [AC_MSG_RESULT([no])])
1371 [test "x$SUDO_BINARY" != "x" -o -w /]) 1371#AC_SUBST(SUDO_BINARY)
1372#AM_CONDITIONAL([HAVE_SUDO],
1373# [test "x$SUDO_BINARY" != "x" -o -w /])
1372 1374
1373# test for doas 1375# test for doas
1374AC_MSG_CHECKING(for doas) 1376AC_MSG_CHECKING(for doas)