aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSchanzenbach, Martin <mschanzenbach@posteo.de>2020-05-06 09:59:57 +0200
committerSchanzenbach, Martin <mschanzenbach@posteo.de>2020-05-06 09:59:57 +0200
commit28697114af2b963651acb03de6685c831e8d2993 (patch)
tree6488b705b904dc50c0bff339cd1f1ea32c89dada /configure.ac
parentca168098bb80966e20ed2d9e18289f3afd14d828 (diff)
downloadgnunet-28697114af2b963651acb03de6685c831e8d2993.tar.gz
gnunet-28697114af2b963651acb03de6685c831e8d2993.zip
improve configure messages more
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac30
1 files changed, 18 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index 6fa8c1d4c..2437df31e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2004,8 +2004,9 @@ AS_IF([test "x$enable_java_ports" = "xyes"],
2004#### 2004####
2005 2005
2006# -- print message regarding enabled experimental features 2006# -- print message regarding enabled experimental features
2007experimental_msg="no"
2007AS_IF([test "x$enable_experimental" = "xyes"], 2008AS_IF([test "x$enable_experimental" = "xyes"],
2008 [experimental_msg="experimental features enabled"]) 2009 [experimental_msg="yes"])
2009# -- OSX Framework 2010# -- OSX Framework
2010AS_IF([test "$enable_framework_build" = "yes"], 2011AS_IF([test "$enable_framework_build" = "yes"],
2011 [macosx_framework_msg="yes"], 2012 [macosx_framework_msg="yes"],
@@ -2035,6 +2036,7 @@ AS_IF([test "x$makeinfo" != "x1"],
2035 [texinfo_msg="no"], 2036 [texinfo_msg="no"],
2036 [texinfo_msg="yes"]) 2037 [texinfo_msg="yes"])
2037# -- conversation 2038# -- conversation
2039conversation_msg="no"
2038AS_IF([test "x$conversation_backend" = "xnone"], 2040AS_IF([test "x$conversation_backend" = "xnone"],
2039 [AS_IF([test "x$pulse" != "x1"], 2041 [AS_IF([test "x$pulse" != "x1"],
2040 [AC_MSG_WARN([libpulse(audio) not found (required to build conversation).]) 2042 [AC_MSG_WARN([libpulse(audio) not found (required to build conversation).])
@@ -2049,12 +2051,13 @@ AS_IF([test "x$conversation_backend" = "xnone"],
2049 gstreamer_msg="no (required for conversation)"], 2051 gstreamer_msg="no (required for conversation)"],
2050 [gstreamer_msg="yes"])], 2052 [gstreamer_msg="yes"])],
2051 [AS_IF([test "x$opus" = x1], 2053 [AS_IF([test "x$opus" = x1],
2052 [features_msg="$features_msg conversation"], 2054 [conversation_msg="yes (x$conversation_backend)"],
2053 [AC_MSG_WARN([libopus not found (required to build conversation)])])]) 2055 [AC_MSG_WARN([libopus not found (required to build conversation)])])])
2054# -- rest 2056# -- rest
2057rest_msg="no"
2055AS_IF([test "x$lmhd" = "x1"], 2058AS_IF([test "x$lmhd" = "x1"],
2056 [AS_IF([test "x$jansson" = "x1"], 2059 [AS_IF([test "x$jansson" = "x1"],
2057 [features_msg="$features_msg rest"], 2060 [rest_msg="yes"],
2058 [AC_MSG_WARN([libjansson not found (required for REST service)])])], 2061 [AC_MSG_WARN([libjansson not found (required for REST service)])])],
2059 [AC_MSG_WARN([libmicrohttpd not found (required for REST service)])]) 2062 [AC_MSG_WARN([libmicrohttpd not found (required for REST service)])])
2060# -- reclaim 2063# -- reclaim
@@ -2081,10 +2084,9 @@ AS_IF([test "$extractor" != 1],
2081 [libextractor_msg="yes"]) 2084 [libextractor_msg="yes"])
2082# -- libzbar 2085# -- libzbar
2083AS_IF([test "x$zbar" = "x1"], 2086AS_IF([test "x$zbar" = "x1"],
2084 [libzbar_msg="yes" 2087 [libzbar_msg="yes"],
2085 features_msg="$features_msg gnunet-qr"],
2086 [AC_MSG_NOTICE([zbar not found, gnunet-qr will not be built.]) 2088 [AC_MSG_NOTICE([zbar not found, gnunet-qr will not be built.])
2087 libzbar_msg="no"]) 2089 libzbar_msg="no (gnunet-qr will not be built)"])
2088# -- libgnurl 2090# -- libgnurl
2089AS_IF([test "$gnurl" = "0"], 2091AS_IF([test "$gnurl" = "0"],
2090 [AS_IF([test "x$curl" = "xfalse"], 2092 [AS_IF([test "x$curl" = "xfalse"],
@@ -2153,8 +2155,8 @@ AC_SUBST(features_msg)
2153# TODO: reduce the length of the last message block, following "IMPORTANT". 2155# TODO: reduce the length of the last message block, following "IMPORTANT".
2154 2156
2155AC_MSG_NOTICE([ 2157AC_MSG_NOTICE([
2156GNUnet Configuration 2158Detected system
2157==================== 2159===============
2158 2160
2159GNUnet version: ${VERSION} 2161GNUnet version: ${VERSION}
2160 2162
@@ -2192,12 +2194,16 @@ libextractor: ${libextractor_msg}
2192texi2mdoc: ${texi2mdoc_msg} 2194texi2mdoc: ${texi2mdoc_msg}
2193mandoc: ${mandoc_msg} 2195mandoc: ${mandoc_msg}
2194 2196
2195texinfo manual: ${texinfo_msg} 2197GNUnet configuration:
2196transpiled mdocml manual: ${mdocml_msg} 2198=====================
2197
2198reclaimID: ${reclaim_msg} 2199reclaimID: ${reclaim_msg}
2199features: ${features_msg} 2200conversation: ${conversation_msg}
2201rest: ${rest_msg}
2202database backends: ${features_msg}
2200experimental: ${experimental_msg} 2203experimental: ${experimental_msg}
2204
2205texinfo manual: ${texinfo_msg}
2206transpiled mdocml manual: ${mdocml_msg}
2201]) 2207])
2202 2208
2203AS_IF([test x$MSG_USER_SETUP != xfalse], 2209AS_IF([test x$MSG_USER_SETUP != xfalse],