aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2019-12-03 18:35:07 +0100
committerChristian Grothoff <christian@grothoff.org>2019-12-03 18:35:07 +0100
commit8732b17ccea679c2ea981b5740a81d4fa7919287 (patch)
treeda62db13987db2b0e6286b2177d676935ac29c7a /configure.ac
parente63133315f334f122ecb39fb574e3ee7584ee9fd (diff)
downloadgnunet-8732b17ccea679c2ea981b5740a81d4fa7919287.tar.gz
gnunet-8732b17ccea679c2ea981b5740a81d4fa7919287.zip
clean up messages from configure related to conversation (#5950)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 10 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 2985b4807..da78d9a75 100644
--- a/configure.ac
+++ b/configure.ac
@@ -571,7 +571,7 @@ AS_IF([test "x$activate_texinfo4" = "xyes"],
571 571
572# Adam shostack suggests the following for Windows: 572# Adam shostack suggests the following for Windows:
573# -D_FORTIFY_SOURCE=2 -fstack-protector-all 573# -D_FORTIFY_SOURCE=2 -fstack-protector-all
574AC_ARG_ENABLE(gcc-hardening, 574AC_ARG_ENABLE([gcc-hardening],
575 AS_HELP_STRING(--enable-gcc-hardening, enable compiler security checks), 575 AS_HELP_STRING(--enable-gcc-hardening, enable compiler security checks),
576[AS_IF([test x$enableval = xyes],[ 576[AS_IF([test x$enableval = xyes],[
577 CFLAGS="$CFLAGS -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -fstack-protector-all" 577 CFLAGS="$CFLAGS -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -fstack-protector-all"
@@ -582,13 +582,13 @@ AC_ARG_ENABLE(gcc-hardening,
582 582
583# Linker hardening options 583# Linker hardening options
584# Currently these options are ELF specific - you can't use this with MacOSX 584# Currently these options are ELF specific - you can't use this with MacOSX
585AC_ARG_ENABLE(linker-hardening, 585AC_ARG_ENABLE([linker-hardening],
586 AS_HELP_STRING(--enable-linker-hardening, enable linker security fixups), 586 AS_HELP_STRING(--enable-linker-hardening, enable linker security fixups),
587[AS_IF([test x$enableval = xyes], 587[AS_IF([test x$enableval = xyes],
588 [LDFLAGS="$LDFLAGS -z relro -z now"])]) 588 [LDFLAGS="$LDFLAGS -z relro -z now"])])
589 589
590 590
591AC_ARG_ENABLE(sanitizer, 591AC_ARG_ENABLE([sanitizer],
592 AS_HELP_STRING(--enable-sanitizer, enable Address Sanitizer and Undefined Behavior Sanitizer), 592 AS_HELP_STRING(--enable-sanitizer, enable Address Sanitizer and Undefined Behavior Sanitizer),
593[AS_IF([test x$enableval = xyes],[ 593[AS_IF([test x$enableval = xyes],[
594 LDFLAGS="$CFLAGS -fsanitize=address,undefined -fno-omit-frame-pointer" 594 LDFLAGS="$CFLAGS -fsanitize=address,undefined -fno-omit-frame-pointer"
@@ -868,7 +868,7 @@ AS_IF([test "x$opus" = x1],
868 [AC_DEFINE([HAVE_OPUS],[1],[Have libopus library]) 868 [AC_DEFINE([HAVE_OPUS],[1],[Have libopus library])
869 libopus_msg="yes"], 869 libopus_msg="yes"],
870 [AC_DEFINE([HAVE_OPUS],[0],[Lacking libopus library]) 870 [AC_DEFINE([HAVE_OPUS],[0],[Lacking libopus library])
871 libopus_msg="no"]) 871 libopus_msg="no (required for conversation)"])
872 872
873# libogg 873# libogg
874AC_MSG_CHECKING(for libogg) 874AC_MSG_CHECKING(for libogg)
@@ -2052,17 +2052,19 @@ AS_IF([test "x$makeinfo" != "x1"],
2052AS_IF([test "x$conversation_backend" = "xnone"], 2052AS_IF([test "x$conversation_backend" = "xnone"],
2053 [AS_IF([test "x$pulse" != "x1"], 2053 [AS_IF([test "x$pulse" != "x1"],
2054 [AC_MSG_WARN([libpulse(audio) not found (required to build conversation).]) 2054 [AC_MSG_WARN([libpulse(audio) not found (required to build conversation).])
2055 libpulse_msg="no"], 2055 libpulse_msg="no (required for conversation)"],
2056 [libpulse_msg="yes"]) 2056 [libpulse_msg="yes"])
2057 AS_IF([test "x$opus" != "x1"], 2057 AS_IF([test "x$opus" != "x1"],
2058 [AC_MSG_WARN([libopus not found (required to build conversation)]) 2058 [AC_MSG_WARN([libopus not found (required to build conversation)])
2059 libopus_msg="no"], 2059 libopus_msg="no (required for conversation)"],
2060 [libopus_msg="yes"]) 2060 [libopus_msg="yes"])
2061 AS_IF([test "x$gst" != "x1"], 2061 AS_IF([test "x$gst" != "x1"],
2062 [AC_MSG_WARN([GStreamer not found (required to build conversation).]) 2062 [AC_MSG_WARN([GStreamer not found (required to build conversation).])
2063 gstreamer_msg="no"], 2063 gstreamer_msg="no (required for conversation)"],
2064 [gstreamer_msg="yes"])], 2064 [gstreamer_msg="yes"])],
2065 [features_msg="$features_msg conversation"]) 2065 [AS_IF([test "x$opus" = x1],
2066 [features_msg="$features_msg conversation"],
2067 [AC_MSG_WARN([libopus not found (required to build conversation)])])])
2066# -- interface 2068# -- interface
2067interface_msg=`echo $DEFAULT_INTERFACE | tr -d \"` 2069interface_msg=`echo $DEFAULT_INTERFACE | tr -d \"`
2068# -- libmicrohttpd 2070# -- libmicrohttpd