aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2020-04-08 14:44:39 +0200
committerChristian Grothoff <christian@grothoff.org>2020-04-08 14:44:39 +0200
commit8c9600879334ce68a72cb1f8de7e6bd156a4b2f2 (patch)
tree55dc396cd14d6826b3b60cc78bd8e87283404641 /configure.ac
parent29bd17729dd74080e0070f09654690200c1e11ae (diff)
downloadgnunet-8c9600879334ce68a72cb1f8de7e6bd156a4b2f2.tar.gz
gnunet-8c9600879334ce68a72cb1f8de7e6bd156a4b2f2.zip
add check to see if CC supports '_Static_assert'
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c57a56f9f..3b3c9cbe9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -691,6 +691,14 @@ AC_RUN_IFELSE(
691AC_LANG_POP(C) 691AC_LANG_POP(C)
692]) # $build = $target 692]) # $build = $target
693 693
694AC_COMPILE_IFELSE([AC_LANG_SOURCE(
695 [[int main() {
696 _Static_assert(sizeof(int) >= 4, "not big enough");
697 return 0;
698 };]])],
699 [AC_DEFINE([HAVE_STATIC_ASSERT],[1],[Static assertions supported])],
700 [AC_DEFINE([HAVE_STATIC_ASSERT],[0],[Static assertions not supported])])
701
694# check for bluetooth library 702# check for bluetooth library
695bluetooth=0 703bluetooth=0
696AC_MSG_CHECKING(for libbluetooth) 704AC_MSG_CHECKING(for libbluetooth)