aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSchanzenbach, Martin <mschanzenbach@posteo.de>2020-05-06 10:25:00 +0200
committerSchanzenbach, Martin <mschanzenbach@posteo.de>2020-05-06 10:25:00 +0200
commita4fddaa4db7d750f270dde337443739b53a7bfcd (patch)
treecbd6b93457e95286e51b7db17a5a8289fd3a535e /configure.ac
parent28697114af2b963651acb03de6685c831e8d2993 (diff)
downloadgnunet-a4fddaa4db7d750f270dde337443739b53a7bfcd.tar.gz
gnunet-a4fddaa4db7d750f270dde337443739b53a7bfcd.zip
stop excessive warnings and notifications of information that is displayed later on anyway
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac30
1 files changed, 11 insertions, 19 deletions
diff --git a/configure.ac b/configure.ac
index 2437df31e..a81e8a9f7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2039,16 +2039,13 @@ AS_IF([test "x$makeinfo" != "x1"],
2039conversation_msg="no" 2039conversation_msg="no"
2040AS_IF([test "x$conversation_backend" = "xnone"], 2040AS_IF([test "x$conversation_backend" = "xnone"],
2041 [AS_IF([test "x$pulse" != "x1"], 2041 [AS_IF([test "x$pulse" != "x1"],
2042 [AC_MSG_WARN([libpulse(audio) not found (required to build conversation).]) 2042 [libpulse_msg="no (required for conversation)"],
2043 libpulse_msg="no (required for conversation)"],
2044 [libpulse_msg="yes"]) 2043 [libpulse_msg="yes"])
2045 AS_IF([test "x$opus" != "x1"], 2044 AS_IF([test "x$opus" != "x1"],
2046 [AC_MSG_WARN([libopus not found (required to build conversation)]) 2045 [libopus_msg="no (required for conversation)"],
2047 libopus_msg="no (required for conversation)"],
2048 [libopus_msg="yes"]) 2046 [libopus_msg="yes"])
2049 AS_IF([test "x$gst" != "x1"], 2047 AS_IF([test "x$gst" != "x1"],
2050 [AC_MSG_WARN([GStreamer not found (required to build conversation).]) 2048 [gstreamer_msg="no (required for conversation)"],
2051 gstreamer_msg="no (required for conversation)"],
2052 [gstreamer_msg="yes"])], 2049 [gstreamer_msg="yes"])],
2053 [AS_IF([test "x$opus" = x1], 2050 [AS_IF([test "x$opus" = x1],
2054 [conversation_msg="yes (x$conversation_backend)"], 2051 [conversation_msg="yes (x$conversation_backend)"],
@@ -2058,8 +2055,8 @@ rest_msg="no"
2058AS_IF([test "x$lmhd" = "x1"], 2055AS_IF([test "x$lmhd" = "x1"],
2059 [AS_IF([test "x$jansson" = "x1"], 2056 [AS_IF([test "x$jansson" = "x1"],
2060 [rest_msg="yes"], 2057 [rest_msg="yes"],
2061 [AC_MSG_WARN([libjansson not found (required for REST service)])])], 2058 [rest_msg="no (libjansson missing)"])],
2062 [AC_MSG_WARN([libmicrohttpd not found (required for REST service)])]) 2059 [rest_msg="no (libmicrohttpd missing)"])
2063# -- reclaim 2060# -- reclaim
2064AS_IF([test "x$lmhd" = "x1"], 2061AS_IF([test "x$lmhd" = "x1"],
2065 [AS_IF([test "x$jansson" = "x1"], 2062 [AS_IF([test "x$jansson" = "x1"],
@@ -2085,8 +2082,7 @@ AS_IF([test "$extractor" != 1],
2085# -- libzbar 2082# -- libzbar
2086AS_IF([test "x$zbar" = "x1"], 2083AS_IF([test "x$zbar" = "x1"],
2087 [libzbar_msg="yes"], 2084 [libzbar_msg="yes"],
2088 [AC_MSG_NOTICE([zbar not found, gnunet-qr will not be built.]) 2085 [libzbar_msg="no (gnunet-qr will not be built)"])
2089 libzbar_msg="no (gnunet-qr will not be built)"])
2090# -- libgnurl 2086# -- libgnurl
2091AS_IF([test "$gnurl" = "0"], 2087AS_IF([test "$gnurl" = "0"],
2092 [AS_IF([test "x$curl" = "xfalse"], 2088 [AS_IF([test "x$curl" = "xfalse"],
@@ -2098,28 +2094,24 @@ AS_IF([test "$gnurl" = "0"],
2098 [gnurl_msg="yes"]) 2094 [gnurl_msg="yes"])
2099# -- ifconfig 2095# -- ifconfig
2100AS_IF([test "$VAR_IFCONFIG_BINARY" = "false"], 2096AS_IF([test "$VAR_IFCONFIG_BINARY" = "false"],
2101 [AC_MSG_WARN([ifconfig not found, some features will not work]) 2097 [ifconfig_msg="no (optional, some features will not work)"],
2102 ifconfig_msg="no (optional)"],
2103 [ifconfig_msg="yes"]) 2098 [ifconfig_msg="yes"])
2104# -- upnpc 2099# -- upnpc
2105AS_IF([test "$VAR_UPNPC_BINARY" = "false"], 2100AS_IF([test "$VAR_UPNPC_BINARY" = "false"],
2106 [AC_MSG_WARN([upnpc binary not found, NAT traversal using UPnPc will not work]) 2101 [upnpc_msg="no (optional, NAT traversal using UPnPc will not work)"],
2107 upnpc_msg="no (optional)"],
2108 [upnpc_msg="yes"]) 2102 [upnpc_msg="yes"])
2109# -- iptables 2103# -- iptables
2110AS_IF([test "$VAR_IPTABLES_BINARY" = "false"], 2104AS_IF([test "$VAR_IPTABLES_BINARY" = "false"],
2111 [AC_MSG_WARN([iptables not found, DNS query interception will not work]) 2105 [iptables_msg="no (optional, DNS query interception will not work)"],
2112 iptables_msg="no (optional)"],
2113 [iptables_msg="yes"]) 2106 [iptables_msg="yes"])
2114# -- bluetooth 2107# -- bluetooth
2115AS_IF([test "x$bluetooth" = "x0"], 2108AS_IF([test "x$bluetooth" = "x0"],
2116 [AC_MSG_NOTICE([bluetooth library not found, will not be able to use Bluetooth]) 2109 [bluetooth_msg="no (optional)"],
2117 bluetooth_msg="no (optional)"],
2118 [bluetooth_msg="yes"]) 2110 [bluetooth_msg="yes"])
2119# -- gnutls 2111# -- gnutls
2120AS_IF([test x$gnutls != xtrue], 2112AS_IF([test x$gnutls != xtrue],
2121 [AC_MSG_WARN([GnuTLS not found, gnunet-gns-proxy will not be built]) 2113 [AC_MSG_WARN([GnuTLS not found, gnunet-gns-proxy will not be built])
2122 gnutls_msg="no"], 2114 gnutls_msg="no (gnunet-gns-proxy will not be built)"],
2123 [AS_IF([test "x$gnutls_dane" != "x1"], 2115 [AS_IF([test "x$gnutls_dane" != "x1"],
2124 [AC_MSG_WARN([GnuTLS lacks DANE support, DANE validation will not be possible]) 2116 [AC_MSG_WARN([GnuTLS lacks DANE support, DANE validation will not be possible])
2125 gnutls_msg="yes (without DANE support)"], 2117 gnutls_msg="yes (without DANE support)"],