aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSchanzenbach, Martin <mschanzenbach@posteo.de>2020-05-06 11:54:44 +0200
committerSchanzenbach, Martin <mschanzenbach@posteo.de>2020-05-06 11:54:44 +0200
commit331a6079913db5e630c113b0e022c9587499d177 (patch)
treeb2f5445b9dd0382eac1082a8bbc25b4cc5c5337a /configure.ac
parente7c277845d37d7e655e65f2289e91305cbbe8f09 (diff)
downloadgnunet-331a6079913db5e630c113b0e022c9587499d177.tar.gz
gnunet-331a6079913db5e630c113b0e022c9587499d177.zip
ignore tautologies; check is necessary
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 10 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index b0bc471f4..089f0493c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -97,6 +97,9 @@ AC_DEFUN([CC_CHECK_CFLAG_APPEND], [
97# We make heavy use of this, llvm/gcc and gcc-9 give warnings so disable. 97# We make heavy use of this, llvm/gcc and gcc-9 give warnings so disable.
98CC_CHECK_CFLAG_APPEND([address-of-packed-member]) 98CC_CHECK_CFLAG_APPEND([address-of-packed-member])
99 99
100# We make heavy use of this, llvm/gcc and gcc-9 give warnings so disable.
101CC_CHECK_CFLAG_APPEND([tautological-constant-out-of-range-compare])
102
100# Use Linux interface name unless the OS has a different preference 103# Use Linux interface name unless the OS has a different preference
101DEFAULT_INTERFACE="\"eth0\"" 104DEFAULT_INTERFACE="\"eth0\""
102 105
@@ -1459,6 +1462,7 @@ AM_CONDITIONAL(HAVE_MHD, test x$lmhd = x1)
1459AC_DEFINE_UNQUOTED([HAVE_MHD], $lmhd, [We have libmicrohttpd]) 1462AC_DEFINE_UNQUOTED([HAVE_MHD], $lmhd, [We have libmicrohttpd])
1460 1463
1461AM_CONDITIONAL(HAVE_JSON, [test x$jansson = x1]) 1464AM_CONDITIONAL(HAVE_JSON, [test x$jansson = x1])
1465AM_CONDITIONAL(HAVE_REST, [test x$jansson = x1 -a x$lmhd = x1])
1462 1466
1463# restore LIBS 1467# restore LIBS
1464LIBS=$SAVE_LIBS 1468LIBS=$SAVE_LIBS
@@ -2034,19 +2038,13 @@ AS_IF([test "x$conversation_backend" = "xnone"],
2034 [AS_IF([test "x$opus" = x1], 2038 [AS_IF([test "x$opus" = x1],
2035 [conversation_msg="yes (x$conversation_backend)"], 2039 [conversation_msg="yes (x$conversation_backend)"],
2036 [AC_MSG_WARN([libopus not found (required to build conversation)])])]) 2040 [AC_MSG_WARN([libopus not found (required to build conversation)])])])
2037# -- rest 2041# -- rest / oidc
2038rest_msg="no" 2042rest_msg="no"
2039AS_IF([test "x$lmhd" = "x1"], 2043AS_IF([test "x$lmhd" = "x1" -a "x$jansson" = "x1"],
2040 [AS_IF([test "x$jansson" = "x1"], 2044 [rest_msg="yes"
2041 [rest_msg="yes"], 2045 reclaim_msg="yes (with OpenID Connect)"],
2042 [rest_msg="no (libjansson missing)"])], 2046 [rest_msg="no"
2043 [rest_msg="no (libmicrohttpd missing)"]) 2047 reclaim_msg="yes (without OpenID Connect)"])
2044# -- reclaim
2045AS_IF([test "x$lmhd" = "x1"],
2046 [AS_IF([test "x$jansson" = "x1"],
2047 [reclaim_msg="yes (with OpenID Connect)"],
2048 [reclaim_msg="yes (without OpenID Connect, missing libjansson)"],
2049 [reclaim_msg="yes (without OpenID Connect, missing libmicrohttpd)"])])
2050 2048
2051 2049
2052# -- interface 2050# -- interface