aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNils Gillmann <ng0@n0.is>2018-09-07 15:41:06 +0000
committerNils Gillmann <ng0@n0.is>2018-09-07 15:41:06 +0000
commit15a3a09d508eed0f6d2612dd42d1b8ea720eb036 (patch)
tree6027869fe8feefc6c3f82b9204fc8ec3b4870d23 /configure.ac
parente7583540d0ec62c21fbf098dd757be5505a8a71d (diff)
downloadgnunet-15a3a09d508eed0f6d2612dd42d1b8ea720eb036.tar.gz
gnunet-15a3a09d508eed0f6d2612dd42d1b8ea720eb036.zip
doc: start work on mdoc generation support
Signed-off-by: Nils Gillmann <ng0@n0.is>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 10991e574..3be070b91 100644
--- a/configure.ac
+++ b/configure.ac
@@ -688,6 +688,24 @@ else
688 AC_DEFINE([DOCUMENTATION],[0],[Not building the documentation]) 688 AC_DEFINE([DOCUMENTATION],[0],[Not building the documentation])
689fi 689fi
690 690
691# TODO: Include check for mandoc + texi2mdoc.
692# TODO: Rename the switch? Just 'section7' is too vague.
693# mdoc section 7 output.
694AC_MSG_CHECKING(wether to build section 7 mdoc output)
695AC_ARG_ENABLE([section7],
696[AS_HELP_STRING([--disable-section7], [do not build section 7 mdoc output])],
697[section7=${enableval}],
698[section7=yes])
699AC_MSG_RESULT($section7)
700if test "x$section7" = "xyes"
701then
702 AM_CONDITIONAL([SECTION7],true)
703 AC_DEFINE([SECTION7],[1],[Building section 7 mdoc output])
704else
705 AM_CONDITIONAL([SECTION7],false)
706 AC_DEFINE([SECTION7],[0],[Not building section 7 mdoc output])
707fi
708
691# should the build process be building only the documentation? 709# should the build process be building only the documentation?
692AC_MSG_CHECKING(whether to build only documentation) 710AC_MSG_CHECKING(whether to build only documentation)
693AC_ARG_ENABLE([documentation-only], 711AC_ARG_ENABLE([documentation-only],