aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNils Gillmann <ng0@n0.is>2018-10-30 12:37:02 +0000
committerNils Gillmann <ng0@n0.is>2018-10-30 12:37:02 +0000
commit62355a754eb4f3e8aa9e9e514ae1bb0e28f51fcc (patch)
treef04519a3932747932c67999f753ea73edf573a23 /configure.ac
parentb5c8dbf1f06aa07996c799e8824eff973e12eb00 (diff)
downloadgnunet-62355a754eb4f3e8aa9e9e514ae1bb0e28f51fcc.tar.gz
gnunet-62355a754eb4f3e8aa9e9e514ae1bb0e28f51fcc.zip
configure: best effort commit (untested) to solve version requirement for makeinfo.
Signed-off-by: Nils Gillmann <ng0@n0.is>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac27
1 files changed, 24 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 208c7772c..e37df28dd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -244,7 +244,6 @@ else
244AC_MSG_WARN([warning: 'ifconfig' not found.]) 244AC_MSG_WARN([warning: 'ifconfig' not found.])
245fi 245fi
246 246
247
248# miniupnpc / upnpc binary is a soft runtime requirement 247# miniupnpc / upnpc binary is a soft runtime requirement
249AC_PATH_TARGET_TOOL(VAR_UPNPC_BINARY, upnpc, false) 248AC_PATH_TARGET_TOOL(VAR_UPNPC_BINARY, upnpc, false)
250 249
@@ -301,10 +300,32 @@ then
301fi 300fi
302AC_DEFINE_UNQUOTED([NEED_LIBGCRYPT_VERSION], "$NEED_LIBGCRYPT_VERSION", [required libgcrypt version]) 301AC_DEFINE_UNQUOTED([NEED_LIBGCRYPT_VERSION], "$NEED_LIBGCRYPT_VERSION", [required libgcrypt version])
303 302
304# TODO: add check for VERSION 303# Check for makeinfo version >= 5, required for building documentation.
304# TODO: invalid version should imply --disable-documentation (and
305# maybe --with-section7).
305# TODO: add check for alternatives 306# TODO: add check for alternatives
306# TODO: add switch to skip documentation building 307# TODO: add switch to skip documentation building
307AM_MISSING_PROG([MAKEINFO], [makeinfo]) 308have_makeinfo_5=false
309AC_PROG_SED
310AC_CHECK_PROG([MAKEINFO_FOUND], [makeinfo], [yes])
311if test x"${MAKEINFO_FOUND}" = xyes
312then
313 MAKEINFO_VERSION_REQ=5
314 AC_MSG_CHECKING([for makeinfo version >= $MAKEINFO_VERSION_REQ])
315 # XXX: is this sed invocation portable?
316 MAKEINFO_VERSION=`makeinfo --version | sed -ne 's/^\(makeinfo\|texi2any\) .* \([[0-9]][[0-9]]*\)\.[[0-9]][[0-9]]*.*$/\2/p'`
317 if test x$MAKEINFO_VERSION = x -o 0$MAKEINFO_VERSION -lt $MAKEINFO_VERSION_REQ
318 then
319 AC_MSG_RESULT([no])
320 AC_MSG_FAILURE([Program 'makeinfo' version >= $MAKEINFO_VERSION_REQ is required.])
321 else
322 AC_MSG_RESULT([yes])
323 have_makeinfo_5=true
324 fi
325else
326 AC_MSG_FAILURE([Missing program 'makeinfo', Documentation will not be built. Please install it if you want 'info' documentation or refer to online resources at 'https://docs.gnunet.org'.])
327fi
328AM_CONDITIONAL([HAVE_MAKEINFO_5], [test x$have_makeinfo_5 = xtrue])
308 329
309# Adam shostack suggests the following for Windows: 330# Adam shostack suggests the following for Windows:
310# -D_FORTIFY_SOURCE=2 -fstack-protector-all 331# -D_FORTIFY_SOURCE=2 -fstack-protector-all