aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2019-02-20 10:05:26 +0100
committerChristian Grothoff <christian@grothoff.org>2019-02-20 10:05:26 +0100
commit756799b50daeaaec1dc0594f1506d83bbef7d4b5 (patch)
treee8a568b3318669537e5c799478703a2cf0ed4396 /configure.ac
parent4a1e326038f86f496af3a33c3786253fe80cdf0a (diff)
downloadgnunet-756799b50daeaaec1dc0594f1506d83bbef7d4b5.tar.gz
gnunet-756799b50daeaaec1dc0594f1506d83bbef7d4b5.zip
fix build system to actually handle openssl.cnf properly
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 2 insertions, 21 deletions
diff --git a/configure.ac b/configure.ac
index b3caee676..8b93d8d6c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -377,10 +377,6 @@ AC_ARG_ENABLE(gcc-hardening,
377 LDFLAGS="$LDFLAGS -pie" 377 LDFLAGS="$LDFLAGS -pie"
378fi]) 378fi])
379 379
380# gnunet-gns-proxy-setup-ca requires openssl and certutil (nss)
381AC_CHECK_PROG(have_openssl, [openssl], [yes], [no])
382AC_CHECK_PROG(have_certutil, [certutil], [yes], [no])
383
384# Linker hardening options 380# Linker hardening options
385# Currently these options are ELF specific - you can't use this with MacOSX 381# Currently these options are ELF specific - you can't use this with MacOSX
386AC_ARG_ENABLE(linker-hardening, 382AC_ARG_ENABLE(linker-hardening,
@@ -1304,6 +1300,8 @@ AC_SUBST(LIBPREFIX)
1304AC_SUBST(DLLDIR) 1300AC_SUBST(DLLDIR)
1305AC_SUBST(EXT_LIB_PATH) 1301AC_SUBST(EXT_LIB_PATH)
1306 1302
1303DATAROOTDIR=$datarootdir
1304AC_SUBST(DATAROOTDIR)
1307 1305
1308# test for sudo 1306# test for sudo
1309AC_MSG_CHECKING(for sudo) 1307AC_MSG_CHECKING(for sudo)
@@ -1443,23 +1441,6 @@ AC_MSG_RESULT($enable_test_run)
1443AM_CONDITIONAL([ENABLE_TEST_RUN], [test "x$enable_tests_run" = "xyes"]) 1441AM_CONDITIONAL([ENABLE_TEST_RUN], [test "x$enable_tests_run" = "xyes"])
1444 1442
1445 1443
1446# should monkey be used when running (certain) services?
1447AC_MSG_CHECKING(whether to run with monkey)
1448AC_ARG_ENABLE([monkey],
1449 [AS_HELP_STRING([--enable-monkey], [enable running with monkey])],
1450 [enable_monkey=${enableval}],
1451 [enable_monkey=no])
1452AC_MSG_RESULT($enable_monkey)
1453AM_CONDITIONAL([ENABLE_MONKEY], [test "x$enable_monkey" = "xyes"])
1454if test "x$enable_monkey" = "xyes"
1455then
1456 MONKEYPREFIX="pathologist -d $(eval echo ${datarootdir}/gnunet/gnunet.sqlite) -p 30 --"
1457else
1458 MONKEYPREFIX=""
1459fi
1460AC_SUBST(MONKEYPREFIX)
1461
1462
1463AC_MSG_CHECKING([whether to compile in benchmarks (currently for http and crypto)]) 1444AC_MSG_CHECKING([whether to compile in benchmarks (currently for http and crypto)])
1464AC_ARG_ENABLE([benchmark], 1445AC_ARG_ENABLE([benchmark],
1465 [AS_HELP_STRING([--enable-benchmark], [enable benchmarking])], 1446 [AS_HELP_STRING([--enable-benchmark], [enable benchmarking])],