aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorng0 <ng0@n0.is>2019-04-01 14:06:27 +0000
committerng0 <ng0@n0.is>2019-04-01 14:06:27 +0000
commit8e50f39a2c1ba03011bd1e5c51d0721f220e2e7a (patch)
treea5fdc478c3350c8945fb77efa41ccf04823522df /configure.ac
parent1238b1f27382971a5ad0ad07ea0ed30b6d3aad17 (diff)
downloadgnunet-8e50f39a2c1ba03011bd1e5c51d0721f220e2e7a.tar.gz
gnunet-8e50f39a2c1ba03011bd1e5c51d0721f220e2e7a.zip
add ability to build manpages independent from other documentation choices
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a8c80eb7d..4f6b69e17 100644
--- a/configure.ac
+++ b/configure.ac
@@ -375,6 +375,21 @@ else
375 AC_DEFINE([DOCUMENTATION_ONLY],[0],[Not building only the documentation]) 375 AC_DEFINE([DOCUMENTATION_ONLY],[0],[Not building only the documentation])
376fi 376fi
377 377
378# should the build process be including the manpages? (default: yes)
379AC_MSG_CHECKING(whether to include man pages)
380AC_ARG_ENABLE([include-manpages],
381 [AS_HELP_STRING([--disable-include-manpages], [Do not include the man pages in build and installation])],
382 [include_manpages=${enableval}],
383 [include_manpages=yes])
384AC_MSG_RESULT($include_manpages)
385if test "x$include_manpages" = "xyes"
386then
387 AM_CONDITIONAL([INCLUDE_MANPAGES],true)
388 AC_DEFINE([INCLUDE_MANPAGES],[1],[Including the man pages in the build and installation])
389else
390 AM_CONDITIONAL([INCLUDE_MANPAGES],false)
391 AC_DEFINE([INCLUDE_MANPAGES],[0],[Not including the man pages in the build and installation])
392fi
378 393
379# Adam shostack suggests the following for Windows: 394# Adam shostack suggests the following for Windows:
380# -D_FORTIFY_SOURCE=2 -fstack-protector-all 395# -D_FORTIFY_SOURCE=2 -fstack-protector-all
@@ -1326,6 +1341,7 @@ DATAROOTDIR=$datarootdir
1326AC_SUBST(DATAROOTDIR) 1341AC_SUBST(DATAROOTDIR)
1327 1342
1328# test for sudo 1343# test for sudo
1344# TODO: do we need to change anything for "doas" on openbsd?
1329AC_MSG_CHECKING(for sudo) 1345AC_MSG_CHECKING(for sudo)
1330AC_ARG_WITH(sudo, 1346AC_ARG_WITH(sudo,
1331 [ --with-sudo=PATH path to sudo binary (or just yes)], 1347 [ --with-sudo=PATH path to sudo binary (or just yes)],