aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorng0 <ng0@n0.is>2019-09-11 12:42:35 +0000
committerng0 <ng0@n0.is>2019-09-11 12:42:35 +0000
commitc4ae64d7988d03a10fd43cf8d0fa81399382fcb3 (patch)
tree021052c6001f6a7898735c0eef53b42848c667ce /configure.ac
parent41d6a90e337d6718d37855fb1e0a5537a319d122 (diff)
downloadgnunet-c4ae64d7988d03a10fd43cf8d0fa81399382fcb3.tar.gz
gnunet-c4ae64d7988d03a10fd43cf8d0fa81399382fcb3.zip
configure: remove mingw conditions, replace one gcc with $CC.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 4 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index ef68f01ee..e11fee997 100644
--- a/configure.ac
+++ b/configure.ac
@@ -62,8 +62,9 @@ AC_FUNC_FSEEKO
62 62
63 63
64CFLAGS="-Wall $CFLAGS" 64CFLAGS="-Wall $CFLAGS"
65AC_MSG_CHECKING(whether cc can use -fno-strict-aliasing)
65# use '-fno-strict-aliasing', but only if the compiler can take it 66# use '-fno-strict-aliasing', but only if the compiler can take it
66AS_IF([gcc -fno-strict-aliasing -S -o /dev/null -xc /dev/null >/dev/null 2>&1], 67AS_IF([$CC -fno-strict-aliasing -S -o /dev/null -xc /dev/null >/dev/null 2>&1],
67 [CFLAGS="-fno-strict-aliasing $CFLAGS"]) 68 [CFLAGS="-fno-strict-aliasing $CFLAGS"])
68 69
69# A helper which allows us to check cflags if compiler 70# A helper which allows us to check cflags if compiler
@@ -197,6 +198,7 @@ AC_SUBST(UNIXONLY)
197AC_MSG_CHECKING([for build target]) 198AC_MSG_CHECKING([for build target])
198AM_CONDITIONAL(DARWIN, test "$build_target" = "darwin") 199AM_CONDITIONAL(DARWIN, test "$build_target" = "darwin")
199AM_CONDITIONAL(SOLARIS, test "$build_target" = "solaris") 200AM_CONDITIONAL(SOLARIS, test "$build_target" = "solaris")
201AM_CONDITIONAL(XNETBSD, test "$build_target" = "netbsd")
200AM_CONDITIONAL(XFREEBSD, test "$build_target" = "freebsd") 202AM_CONDITIONAL(XFREEBSD, test "$build_target" = "freebsd")
201AM_CONDITIONAL(OPENBSD, test "$build_target" = "openbsd") 203AM_CONDITIONAL(OPENBSD, test "$build_target" = "openbsd")
202AM_CONDITIONAL(LINUX, test "$build_target" = "linux") 204AM_CONDITIONAL(LINUX, test "$build_target" = "linux")
@@ -319,8 +321,6 @@ AC_CHECK_MEMBER(struct tm.tm_gmtoff,
319 , 321 ,
320 [#include <time.h>]) 322 [#include <time.h>])
321 323
322AC_CHECK_DECLS([_stati64])
323
324# 'save' libs; only those libs found so far will be 324# 'save' libs; only those libs found so far will be
325# linked against _everywhere_. For the others, we 325# linked against _everywhere_. For the others, we
326# will be more selective! 326# will be more selective!
@@ -593,8 +593,6 @@ AC_LANG_POP(C)
593# check for bluetooth library 593# check for bluetooth library
594bluetooth=0 594bluetooth=0
595CHECK_LIBHEADER(BLUETOOTH, bluetooth, ba2str, bluetooth/bluetooth.h,bluetooth=1,) 595CHECK_LIBHEADER(BLUETOOTH, bluetooth, ba2str, bluetooth/bluetooth.h,bluetooth=1,)
596AS_IF([test "$build_target" = "mingw"],
597 [bluetooth=1])
598AM_CONDITIONAL(HAVE_LIBBLUETOOTH, [test "$bluetooth" = 1]) 596AM_CONDITIONAL(HAVE_LIBBLUETOOTH, [test "$bluetooth" = 1])
599AS_IF([test "$bluetooth" = 1], 597AS_IF([test "$bluetooth" = 1],
600 [AC_DEFINE([HAVE_LIBBLUETOOTH],[1],[Have bluetooth library])], 598 [AC_DEFINE([HAVE_LIBBLUETOOTH],[1],[Have bluetooth library])],
@@ -657,8 +655,6 @@ AS_IF([test "x$jansson" = x1],
657pulse=0 655pulse=0
658libpulse_msg="no" 656libpulse_msg="no"
659CHECK_LIBHEADER(LIBPULSE, pulse, pa_stream_peek, pulse/simple.h,pulse=1,) 657CHECK_LIBHEADER(LIBPULSE, pulse, pa_stream_peek, pulse/simple.h,pulse=1,)
660AS_IF([test "$build_target" = "mingw"],
661 [pulse=0])
662AS_IF([test "$pulse" = 1], 658AS_IF([test "$pulse" = 1],
663 [AC_DEFINE([HAVE_PULSE],[1],[Have libpulse(audio) library]) 659 [AC_DEFINE([HAVE_PULSE],[1],[Have libpulse(audio) library])
664 libpulse_msg="yes"]) 660 libpulse_msg="yes"])
@@ -1916,7 +1912,7 @@ AC_SUBST(features_msg)
1916# TODO: reduce the length of the last message block ("the message") 1912# TODO: reduce the length of the last message block ("the message")
1917 1913
1918AC_MSG_NOTICE([ 1914AC_MSG_NOTICE([
1919GNUnet Configuration (incomplete!) 1915GNUnet Configuration
1920 1916
1921gnunet version: ${VERSION} 1917gnunet version: ${VERSION}
1922 1918