summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorFlorian Dold <florian.dold@gmail.com>2019-05-09 14:51:50 +0200
committerFlorian Dold <florian.dold@gmail.com>2019-05-09 14:54:00 +0200
commit67c3314628930be7e6a9d224456c8dac0f4c8fd4 (patch)
tree6d4a141ee37d13aaea3435a1621ca4e323b7ff3f /configure.ac
parent95096540e381d784ab0d28b6cde2935b9b269558 (diff)
downloadgnunet-67c3314628930be7e6a9d224456c8dac0f4c8fd4.tar.gz
gnunet-67c3314628930be7e6a9d224456c8dac0f4c8fd4.zip
towards thread-safe logging
(Thread-safe logging isn't really relevant for GNUnet itself, but it is necessary for the GNU Taler exchange)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e00b8ae1b..b1e1c1aca 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1795,6 +1795,20 @@ else
1795fi 1795fi
1796AC_DEFINE_UNQUOTED([ENABLE_WINDOWS_WORKAROUNDS], $workarounds, [enable workarounds used on Windows (only useful for test cases)]) 1796AC_DEFINE_UNQUOTED([ENABLE_WINDOWS_WORKAROUNDS], $workarounds, [enable workarounds used on Windows (only useful for test cases)])
1797 1797
1798
1799# Check if the __thread storage class for thread-local storage is available.
1800AC_MSG_CHECKING(whether __thread is supported)
1801AC_LINK_IFELSE(
1802 [AC_LANG_PROGRAM([#include <stdlib.h>
1803 #undef __thread
1804 static __thread int a = 1;],
1805 [exit(a-1);])],
1806 [have_thread_local_gcc=1],[have_thread_local_gcc=0])
1807AC_DEFINE_UNQUOTED([HAVE_THREAD_LOCAL_GCC],$have_thread_local_gcc,[Define this if __thread is supported])
1808AS_IF([test "x$have_thread_local_gcc" = "x1"],
1809 [AC_MSG_RESULT(yes)],
1810 [AC_MSG_RESULT(no)])
1811
1798# gcov compilation 1812# gcov compilation
1799AC_MSG_CHECKING(whether to compile with support for code coverage analysis) 1813AC_MSG_CHECKING(whether to compile with support for code coverage analysis)
1800AC_ARG_ENABLE([coverage], 1814AC_ARG_ENABLE([coverage],