aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorng0 <ng0@n0.is>2019-09-11 11:18:25 +0000
committerng0 <ng0@n0.is>2019-09-11 11:18:25 +0000
commit2b36628d0b617f1c340a04191a485cea5ee23e6f (patch)
tree0479e0128273c0132c7fcf081ba616f111a45d70 /configure.ac
parentd5bd0b9e37d5c5b1bf1c0af6af2dea5ad471b3ce (diff)
downloadgnunet-2b36628d0b617f1c340a04191a485cea5ee23e6f.tar.gz
gnunet-2b36628d0b617f1c340a04191a485cea5ee23e6f.zip
configure: remove windows specific checks.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac110
1 files changed, 1 insertions, 109 deletions
diff --git a/configure.ac b/configure.ac
index 59d236d4f..645b1125e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1051,7 +1051,7 @@ AM_ICONV
1051gl_LIBUNISTRING 1051gl_LIBUNISTRING
1052AS_IF([test $HAVE_LIBUNISTRING != yes], 1052AS_IF([test $HAVE_LIBUNISTRING != yes],
1053 [AC_MSG_ERROR([GNUnet requires libunistring])]) 1053 [AC_MSG_ERROR([GNUnet requires libunistring])])
1054 1054
1055# under emscripten, $gl_libunistring_hexversion is undefined 1055# under emscripten, $gl_libunistring_hexversion is undefined
1056if test "$taler_only" != yes; then 1056if test "$taler_only" != yes; then
1057 1057
@@ -1569,114 +1569,6 @@ AC_ARG_ENABLE([heapstats],
1569AC_MSG_RESULT($enable_heapstats) 1569AC_MSG_RESULT($enable_heapstats)
1570AC_DEFINE_UNQUOTED([ENABLE_HEAP_STATISTICS],$enable_heapstats,[enable expensive heap statistics]) 1570AC_DEFINE_UNQUOTED([ENABLE_HEAP_STATISTICS],$enable_heapstats,[enable expensive heap statistics])
1571 1571
1572# should code be enabled that works around missing OS functionality on Windows?
1573# used for test cases
1574if test $build_target = "mingw"
1575then
1576 workarounds=1
1577
1578AC_LINK_IFELSE(
1579 [AC_LANG_PROGRAM(
1580 [#include <ws2tcpip.h>
1581 ],[
1582 int s = socket (0, 0, 0);])
1583 ],[
1584 AC_DEFINE_UNQUOTED([HAVE_SOCKET],1,[Define this if socket() is available])
1585 ],[
1586 AC_DEFINE_UNQUOTED([HAVE_SOCKET],0,[Define this if socket() is available])
1587 ])
1588
1589AC_LINK_IFELSE(
1590 [AC_LANG_PROGRAM(
1591 [#include <ws2tcpip.h>
1592 ],[
1593 int s = select (0, NULL, NULL, NULL, NULL);])
1594 ],[
1595 AC_DEFINE_UNQUOTED([HAVE_SELECT],1,[Define this if select() is available])
1596 ],[
1597 AC_DEFINE_UNQUOTED([HAVE_SELECT],0,[Define this if select() is available])
1598 ])
1599
1600AC_LINK_IFELSE(
1601 [AC_LANG_PROGRAM(
1602 [#include <ws2tcpip.h>
1603 ],[
1604 struct in_addr i;
1605 char *s = inet_ntoa (i);])
1606 ],[
1607 AC_DEFINE_UNQUOTED([HAVE_INET_NTOA],1,[Define this if inet_ntoa() is available])
1608 ],[
1609 AC_DEFINE_UNQUOTED([HAVE_INET_NTOA],0,[Define this if inet_ntoa() is available])
1610 ])
1611
1612AC_LINK_IFELSE(
1613 [AC_LANG_PROGRAM(
1614 [#include <ws2tcpip.h>
1615 ],[
1616 int s = getnameinfo (NULL, 0, NULL, 0, NULL, 0, 0);])
1617 ],[
1618 AC_DEFINE_UNQUOTED([HAVE_GETNAMEINFO],1,[Define this if getnameinfo() is available])
1619 ],[
1620 AC_DEFINE_UNQUOTED([HAVE_GETNAMEINFO],0,[Define this if getnameinfo() is available])
1621 ])
1622
1623AC_LINK_IFELSE(
1624 [AC_LANG_PROGRAM(
1625 [#include <ws2tcpip.h>
1626 ],[
1627 int s = gethostname (NULL, 0);])
1628 ],[
1629 AC_DEFINE_UNQUOTED([HAVE_GETHOSTNAME],1,[Define this if gethostname() is available])
1630 ],[
1631 AC_DEFINE_UNQUOTED([HAVE_GETHOSTNAME],0,[Define this if gethostname() is available])
1632 ])
1633
1634AC_LINK_IFELSE(
1635 [AC_LANG_PROGRAM(
1636 [#include <ws2tcpip.h>
1637 ],[
1638 void *s = gethostbyname (NULL);])
1639 ],[
1640 AC_DEFINE_UNQUOTED([HAVE_GETHOSTBYNAME],1,[Define this if gethostbyname() is available])
1641 ],[
1642 AC_DEFINE_UNQUOTED([HAVE_GETHOSTBYNAME],0,[Define this if gethostbyname() is available])
1643 ])
1644
1645AC_LINK_IFELSE(
1646 [AC_LANG_PROGRAM(
1647 [#include <ws2tcpip.h>
1648 ],[
1649 void *s = gethostbyaddr (NULL, 0, 0);])
1650 ],[
1651 AC_DEFINE_UNQUOTED([HAVE_GETHOSTBYADDR],1,[Define this if gethostbyaddr() is available])
1652 ],[
1653 AC_DEFINE_UNQUOTED([HAVE_GETHOSTBYADDR],0,[Define this if gethostbyaddr() is available])
1654 ])
1655
1656AC_LINK_IFELSE(
1657 [AC_LANG_PROGRAM(
1658 [#include <ws2tcpip.h>
1659 ],[
1660 int s = getaddrinfo (NULL, NULL, NULL, NULL);])
1661 ],[
1662 AC_DEFINE_UNQUOTED([HAVE_GETADDRINFO],1,[Define this if getaddrinfo() is available])
1663 ],[
1664 AC_DEFINE_UNQUOTED([HAVE_GETADDRINFO],0,[Define this if getaddrinfo() is available])
1665 ])
1666
1667else
1668 AC_MSG_CHECKING(whether to enable windows workarounds)
1669 AC_ARG_ENABLE([windows_workarounds],
1670 [AS_HELP_STRING([--enable-windows_workarounds], [enable workarounds used on Windows (only useful for test cases)])],
1671 [enable_workarounds=${enableval}],
1672 [enable_workarounds=no])
1673 AC_MSG_RESULT($enable_workarounds)
1674 AS_IF([test x$enable_windows_workarounds = "xyes"],
1675 [workarounds=1],
1676 [workarounds=0])
1677fi
1678AC_DEFINE_UNQUOTED([ENABLE_WINDOWS_WORKAROUNDS], $workarounds, [enable workarounds used on Windows (only useful for test cases)])
1679
1680 1572
1681# Check if the __thread storage class for 1573# Check if the __thread storage class for
1682# thread-local storage is available. 1574# thread-local storage is available.