aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorng0 <ng0@n0.is>2019-10-26 12:03:58 +0000
committerng0 <ng0@n0.is>2019-10-26 12:03:58 +0000
commitc074e07068940dd4a60bef8bcea8df31c3df45ca (patch)
treec2b44a8399c10dc94b2850dfe69e20cc7ed8ddea /configure.ac
parent49b41f0bdbcdaf8ce8ef09a876288790e0ceea0a (diff)
downloadgnunet-c074e07068940dd4a60bef8bcea8df31c3df45ca.tar.gz
gnunet-c074e07068940dd4a60bef8bcea8df31c3df45ca.zip
configure: Add --with[out]-libbluetooth=PREFIX
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac33
1 files changed, 30 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index fc0d75fbf..ba8fdb8c6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -605,11 +605,38 @@ AC_LANG_POP(C)
605 605
606# check for bluetooth library 606# check for bluetooth library
607bluetooth=0 607bluetooth=0
608CHECK_LIBHEADER(BLUETOOTH, bluetooth, ba2str, bluetooth/bluetooth.h,bluetooth=1,) 608AC_MSG_CHECKING(for libbluetooth)
609AC_ARG_WITH(libbluetooth,
610 [ --with-libbluetooth=PREFIX (base of libbluetooth installation)],
611 [AC_MSG_RESULT([$with_libbluetooth])
612 AS_CASE([$with_libbluetooth],
613 [no],[],
614 [yes],[
615 CHECK_LIBHEADER(BLUETOOTH,
616 bluetooth,
617 ba2str,
618 bluetooth/bluetooth.h,
619 bluetooth=1,)
620 ],[
621 LDFLAGS="-L$with_libbluetooth/lib $LDFLAGS"
622 CPPFLAGS="-I$with_libbluetooth/include $CPPFLAGS"
623 AC_CHECK_HEADERS(bluetooth/bluetooth.h,
624 AC_CHECK_LIB([bluetooth],
625 [ba2str],
626 EXT_LIB_PATH="-L$with_libbluetooth/lib $EXT_LIB_PATH"
627 bluetooth=1))
628 ])
629 ],
630 [AC_MSG_RESULT([--with-libbluetooth not specified])
631 CHECK_LIBHEADER(BLUETOOTH,
632 bluetooth,
633 ba2str,
634 bluetooth/bluetooth.h,
635 bluetooth=1,)])
609AM_CONDITIONAL(HAVE_LIBBLUETOOTH, [test "$bluetooth" = 1]) 636AM_CONDITIONAL(HAVE_LIBBLUETOOTH, [test "$bluetooth" = 1])
610AS_IF([test "$bluetooth" = 1], 637AS_IF([test "$bluetooth" = 1],
611 [AC_DEFINE([HAVE_LIBBLUETOOTH],[1],[Have bluetooth library])], 638 [AC_DEFINE([HAVE_LIBBLUETOOTH],[1],[Have bluetooth library])],
612 [AC_DEFINE([HAVE_LIBBLUETOOTH],[0],[Lacking bluetooth library])]) 639 [AC_DEFINE([HAVE_LIBBLUETOOTH],[0],[Lacking bluetooth library])])
613 640
614# check for zbar library 641# check for zbar library
615zbar=0 642zbar=0