aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorng0 <ng0@n0.is>2018-01-14 21:30:59 +0000
committerng0 <ng0@n0.is>2018-01-14 21:30:59 +0000
commit020893243a2dde911d5853ade8070fcef9c5fad9 (patch)
tree5c335c4d51d758e36046e969feebab222ac38938 /configure.ac
parent8e9d7943d18cf5b941804829fec6c9ebbf9dfd46 (diff)
downloadgnunet-020893243a2dde911d5853ade8070fcef9c5fad9.tar.gz
gnunet-020893243a2dde911d5853ade8070fcef9c5fad9.zip
Makefile, configure.ac, doc/Makefile: Add the ability to opt-out of documentation building with --disable-documentation, defaults to --enable-documentation
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 10 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 68922e6c0..145a6aaff 100644
--- a/configure.ac
+++ b/configure.ac
@@ -597,19 +597,19 @@ AC_CHECK_LIB([kstat],[kstat_open])
597 597
598# should the build process be restricted to only building 598# should the build process be restricted to only building
599# the documentation? 599# the documentation?
600AC_MSG_CHECKING(whether to build documentation ONLY) 600AC_MSG_CHECKING(whether to build documentation)
601AC_ARG_ENABLE([documentation], 601AC_ARG_ENABLE([documentation],
602 [AS_HELP_STRING([--enable-documentation], [only build the documentation])], 602 [AS_HELP_STRING([--enable-documentation], [build the documentation])],
603 [doc_only=${enableval}], 603 [documentation=${enableval}],
604 [doc_only=no]) 604 [documentation=yes])
605AC_MSG_RESULT($doc_only) 605AC_MSG_RESULT($documentation)
606if test "x$doc_only" = "xyes" 606if test "x$documentation" = "xyes"
607then 607then
608 AM_CONDITIONAL([DOC_ONLY],true) 608 AM_CONDITIONAL([DOCUMENTATION],true)
609 AC_DEFINE([DOC_ONLY],[1],[Building the documentation]) 609 AC_DEFINE([DOCUMENTATION],[1],[Building the documentation])
610else 610else
611 AM_CONDITIONAL([DOC_ONLY],false) 611 AM_CONDITIONAL([DOCUMENTATION],false)
612 AC_DEFINE([DOC_ONLY],[0],[Canonical compilation]) 612 AC_DEFINE([DOCUMENTATION],[0],[Not building the documentation])
613fi 613fi
614 614
615# should the build process be restricted to the code required 615# should the build process be restricted to the code required