aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2017-07-18 22:55:09 +0200
committerChristian Grothoff <christian@grothoff.org>2017-07-18 22:55:09 +0200
commit29f76b6fe373cd5ca7504be2ffdaad5500406b8b (patch)
tree876288c547157e4e39ea3c6f110babcc4326e44c /configure.ac
parentcd8ffdb973670871d8fae691671fc0eb0f3c7ba3 (diff)
downloadgnunet-29f76b6fe373cd5ca7504be2ffdaad5500406b8b.tar.gz
gnunet-29f76b6fe373cd5ca7504be2ffdaad5500406b8b.zip
simplify installation of nss plugins in build system, require user(s) to move plugins into place manually (#5078)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac47
1 files changed, 0 insertions, 47 deletions
diff --git a/configure.ac b/configure.ac
index c16fbdcba..101fc77cb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1116,45 +1116,6 @@ AC_SUBST(SUDO_BINARY)
1116AM_CONDITIONAL([HAVE_SUDO], [test "x$SUDO_BINARY" != "x" -o -w /]) 1116AM_CONDITIONAL([HAVE_SUDO], [test "x$SUDO_BINARY" != "x" -o -w /])
1117 1117
1118 1118
1119# test for nssdir
1120AC_MSG_CHECKING(with nssdir)
1121AC_ARG_WITH(nssdir,
1122 [ --with-nssdir=PATH where to install NSS plugins],
1123 [AC_MSG_RESULT("$with_nssdir")
1124 case $with_nssdir in
1125 no)
1126 NSS_DIR=
1127 install_nss=0
1128 ;;
1129 yes)
1130 NSS_DIR="/lib"
1131 install_nss=1
1132 ;;
1133 *)
1134 NSS_DIR=$with_nssdir
1135 install_nss=1
1136 ;;
1137 esac
1138 ],
1139 [
1140# This test is inappropriate when installation with DESTDIR is
1141# run much later and uid will be root when needed. Enabling this
1142# code breaks the gnunet.ebuild for gentoo.
1143#
1144# if test "x$SUDO_BINARY" != "x" -o -w /
1145# then
1146 NSS_DIR="/lib"
1147 install_nss=1
1148 AC_MSG_RESULT([yes, to /lib])
1149# else
1150# NSS_DIR=
1151# install_nss=0
1152# AC_MSG_RESULT([no])
1153# fi
1154 ])
1155AC_SUBST(NSS_DIR)
1156AM_CONDITIONAL([INSTALL_NSS], [test "x$install_nss" != "x0"])
1157
1158# test for gnunetdns group name 1119# test for gnunetdns group name
1159GNUNETDNS_GROUP=gnunetdns 1120GNUNETDNS_GROUP=gnunetdns
1160AC_MSG_CHECKING(for gnunetdns group name) 1121AC_MSG_CHECKING(for gnunetdns group name)
@@ -1793,14 +1754,6 @@ then
1793 AC_MSG_NOTICE([Mac OS X framework build enabled.]) 1754 AC_MSG_NOTICE([Mac OS X framework build enabled.])
1794fi 1755fi
1795 1756
1796if test "x$install_nss" = "x0"
1797then
1798 AC_MSG_NOTICE([WARNING: Will not install GNS NSS library])
1799else
1800 AC_MSG_NOTICE([NOTICE: Will install GNS NSS library to $NSS_DIR])
1801fi
1802
1803
1804AC_MSG_NOTICE([******************************************** 1757AC_MSG_NOTICE([********************************************
1805Please make sure NOW that you have created a user and group 'gnunet' 1758Please make sure NOW that you have created a user and group 'gnunet'
1806and additionally a group 'gnunetdns'. On Debian and Ubuntu GNU/Linux, type: 1759and additionally a group 'gnunetdns'. On Debian and Ubuntu GNU/Linux, type: