aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorpsyc://loupsycedyglgamf.onion/~lynX <ircs://psyced.org/youbroketheinternet>2017-06-11 04:09:02 +0000
committerpsyc://loupsycedyglgamf.onion/~lynX <ircs://psyced.org/youbroketheinternet>2017-06-11 04:09:02 +0000
commit4b32469e56fd7751165574ad2b13ee0ef7efad31 (patch)
tree36bc8141f90e864d6cb2afcbb0b007f139dcadc0 /configure.ac
parent4bf9e0471759ddd348fe6a800a242e61152033f5 (diff)
downloadgnunet-4b32469e56fd7751165574ad2b13ee0ef7efad31.tar.gz
gnunet-4b32469e56fd7751165574ad2b13ee0ef7efad31.zip
configure.ac: don't make guesses which uid 'make install' will have
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac57
1 files changed, 30 insertions, 27 deletions
diff --git a/configure.ac b/configure.ac
index 45a4878f7..c16fbdcba 100644
--- a/configure.ac
+++ b/configure.ac
@@ -71,7 +71,7 @@ case "$host_os" in
71 AC_DEFINE_UNQUOTED(DARWIN,1,[This is an Apple Darwin system]) 71 AC_DEFINE_UNQUOTED(DARWIN,1,[This is an Apple Darwin system])
72 CPPFLAGS="-D_APPLE_C_SOURCE $CPPFLAGS" 72 CPPFLAGS="-D_APPLE_C_SOURCE $CPPFLAGS"
73 CFLAGS="-fno-common $CFLAGS" 73 CFLAGS="-fno-common $CFLAGS"
74 AC_MSG_WARN([The VPN application cannot be compiled on your OS]) 74 AC_MSG_WARN([WARNING: The VPN application cannot be compiled on your OS])
75 build_target="darwin" 75 build_target="darwin"
76 DEFAULT_INTERFACE="\"en0\"" 76 DEFAULT_INTERFACE="\"en0\""
77 LIBPREFIX= 77 LIBPREFIX=
@@ -522,7 +522,7 @@ then
522 AM_CONDITIONAL(HAVE_LIBCURL, false) 522 AM_CONDITIONAL(HAVE_LIBCURL, false)
523if test "$gnurl" = 0 523if test "$gnurl" = 0
524then 524then
525 AC_MSG_WARN([GNUnet requires libcurl-gnutls or gnurl >= 7.34]) 525 AC_MSG_WARN([ERROR: GNUnet requires libcurl-gnutls or gnurl >= 7.34])
526fi 526fi
527else 527else
528 AM_CONDITIONAL(HAVE_LIBCURL, true) 528 AM_CONDITIONAL(HAVE_LIBCURL, true)
@@ -542,19 +542,18 @@ AC_CHECK_MEMBERS(glp_iocp.presolve,,[gplk=false],[[#include <glpk.h>]])
542if test x$gplk = xfalse 542if test x$gplk = xfalse
543then 543then
544 AM_CONDITIONAL(HAVE_LIBGLPK, false) 544 AM_CONDITIONAL(HAVE_LIBGLPK, false)
545 AC_MSG_WARN([GNUnet requires GLPK >= 4.32]) 545 AC_MSG_WARN([ERROR: GNUnet requires GLPK >= 4.32])
546else 546else
547 AM_CONDITIONAL(HAVE_LIBGLPK, true) 547 AM_CONDITIONAL(HAVE_LIBGLPK, true)
548 AC_DEFINE([HAVE_LIBGLPK],[1],[Have GLPK]) 548 AC_DEFINE([HAVE_LIBGLPK],[1],[Have GLPK])
549fi 549fi
550 550
551 551
552
553AC_CHECK_HEADERS([nss.h],[nss=true],[nss=false]) 552AC_CHECK_HEADERS([nss.h],[nss=true],[nss=false])
554if test x$nss = xfalse 553if test x$nss = xfalse
555then 554then
556 AM_CONDITIONAL(HAVE_GLIBCNSS, false) 555 AM_CONDITIONAL(HAVE_GLIBCNSS, false)
557 AC_MSG_WARN([No GNU libc nss header, will not build NSS plugin]) 556 AC_MSG_WARN([ERROR: No GNU libc nss header, will not build NSS plugin])
558else 557else
559 AM_CONDITIONAL(HAVE_GLIBCNSS, true) 558 AM_CONDITIONAL(HAVE_GLIBCNSS, true)
560fi 559fi
@@ -1138,16 +1137,20 @@ AC_ARG_WITH(nssdir,
1138 esac 1137 esac
1139 ], 1138 ],
1140 [ 1139 [
1141 if test "x$SUDO_BINARY" != "x" -o -w / 1140# This test is inappropriate when installation with DESTDIR is
1142 then 1141# run much later and uid will be root when needed. Enabling this
1142# code breaks the gnunet.ebuild for gentoo.
1143#
1144# if test "x$SUDO_BINARY" != "x" -o -w /
1145# then
1143 NSS_DIR="/lib" 1146 NSS_DIR="/lib"
1144 install_nss=1 1147 install_nss=1
1145 AC_MSG_RESULT([yes, to /lib]) 1148 AC_MSG_RESULT([yes, to /lib])
1146 else 1149# else
1147 NSS_DIR= 1150# NSS_DIR=
1148 install_nss=0 1151# install_nss=0
1149 AC_MSG_RESULT([no]) 1152# AC_MSG_RESULT([no])
1150 fi 1153# fi
1151 ]) 1154 ])
1152AC_SUBST(NSS_DIR) 1155AC_SUBST(NSS_DIR)
1153AM_CONDITIONAL([INSTALL_NSS], [test "x$install_nss" != "x0"]) 1156AM_CONDITIONAL([INSTALL_NSS], [test "x$install_nss" != "x0"])
@@ -1704,7 +1707,7 @@ AC_OUTPUT
1704# warn user if mysql found but not used due to version 1707# warn user if mysql found but not used due to version
1705if test "$mysqlfail" = "true" 1708if test "$mysqlfail" = "true"
1706then 1709then
1707 AC_MSG_NOTICE([NOTICE: MySQL found, but too old. MySQL support will not be compiled.]) 1710 AC_MSG_NOTICE([WARNING: MySQL found, but too old. MySQL support will not be compiled.])
1708fi 1711fi
1709 1712
1710# sqlite 1713# sqlite
@@ -1718,7 +1721,7 @@ if test "$gnurl" = "0"
1718then 1721then
1719 if test "x$curl" = "xfalse" 1722 if test "x$curl" = "xfalse"
1720 then 1723 then
1721 AC_MSG_NOTICE([NOTICE: libgnurl not found. http client support will not be compiled.]) 1724 AC_MSG_NOTICE([WARNING: libgnurl not found. http client support will not be compiled.])
1722 AC_MSG_WARN([ERROR: libgnurl not found. hostlist daemon will not be compiled, and you probably WANT the hostlist daemon]) 1725 AC_MSG_WARN([ERROR: libgnurl not found. hostlist daemon will not be compiled, and you probably WANT the hostlist daemon])
1723 else 1726 else
1724 AC_MSG_NOTICE([WARNING: libgnurl not found, trying to use libcurl-gnutls instead.]) 1727 AC_MSG_NOTICE([WARNING: libgnurl not found, trying to use libcurl-gnutls instead.])
@@ -1729,36 +1732,36 @@ fi
1729# bluetooth 1732# bluetooth
1730if test "x$bluetooth" = "x0" 1733if test "x$bluetooth" = "x0"
1731then 1734then
1732 AC_MSG_NOTICE([NOTICE: bluetooth library not found. bluetooth support will not be compiled.]) 1735 AC_MSG_NOTICE([WARNING: bluetooth library not found. bluetooth support will not be compiled.])
1733fi 1736fi
1734 1737
1735# jansson 1738# jansson
1736if test "x$jansson" = "x0" 1739if test "x$jansson" = "x0"
1737then 1740then
1738 AC_MSG_NOTICE([NOTICE: jansson library not found. json support will not be compiled.]) 1741 AC_MSG_NOTICE([WARNING: jansson library not found. json support will not be compiled.])
1739fi 1742fi
1740 1743
1741#gnutls 1744#gnutls
1742if test x$gnutls != xtrue 1745if test x$gnutls != xtrue
1743then 1746then
1744 AC_MSG_NOTICE([NOTICE: GnuTLS not found, gnunet-gns-proxy will not be built]) 1747 AC_MSG_NOTICE([WARNING: GnuTLS not found, gnunet-gns-proxy will not be built])
1745else 1748else
1746if test "x$gnutls_dane" != "x1" 1749if test "x$gnutls_dane" != "x1"
1747then 1750then
1748 AC_MSG_NOTICE([NOTICE: GnuTLS has no DANE support, DANE validation will not be possible]) 1751 AC_MSG_NOTICE([WARNING: GnuTLS has no DANE support, DANE validation will not be possible])
1749fi 1752fi
1750fi 1753fi
1751 1754
1752# java ports 1755# java ports
1753if test "x$enable_java_ports" = "xyes" 1756if test "x$enable_java_ports" = "xyes"
1754then 1757then
1755 AC_MSG_NOTICE([NOTICE: opening ports for gnunet-java bindings by default.]) 1758 AC_MSG_NOTICE([NOTICE: Opening ports for gnunet-java bindings by default.])
1756fi 1759fi
1757 1760
1758# MHD 1761# MHD
1759if test "x$lmhd" != "x1" 1762if test "x$lmhd" != "x1"
1760then 1763then
1761 AC_MSG_NOTICE([NOTICE: libmicrohttpd not found, http transport will not be installed.]) 1764 AC_MSG_NOTICE([WARNING: libmicrohttpd not found, http transport will not be installed.])
1762fi 1765fi
1763 1766
1764# conversation 1767# conversation
@@ -1766,35 +1769,35 @@ if test "x$conversation_backend" = "xnone"
1766then 1769then
1767 if test "x$pulse" != "x1" 1770 if test "x$pulse" != "x1"
1768 then 1771 then
1769 AC_MSG_NOTICE([NOTICE: libpulse(audio) not found, conversation will not be built.]) 1772 AC_MSG_NOTICE([WARNING: libpulse(audio) not found, conversation will not be built.])
1770 fi 1773 fi
1771 if test "x$opus" != "x1" 1774 if test "x$opus" != "x1"
1772 then 1775 then
1773 AC_MSG_NOTICE([NOTICE: libopus not found, conversation will not be built.]) 1776 AC_MSG_NOTICE([WARNING: libopus not found, conversation will not be built.])
1774 fi 1777 fi
1775 if test "x$gst" != "x1" 1778 if test "x$gst" != "x1"
1776 then 1779 then
1777 AC_MSG_NOTICE([NOTICE: GStreamer not found, conversation will not be built.]) 1780 AC_MSG_NOTICE([WARNING: GStreamer not found, conversation will not be built.])
1778 fi 1781 fi
1779fi 1782fi
1780 1783
1781if test "$extractor" != 1 1784if test "$extractor" != 1
1782then 1785then
1783 AC_MSG_WARN([NOTICE: libextractor not found, but various file-sharing functions require it]) 1786 AC_MSG_WARN([ERROR: libextractor not found, but various file-sharing functions require it])
1784fi 1787fi
1785 1788
1786AC_MSG_NOTICE([NOTICE: Database support is set to MySQL: $mysql, SQLite: $sqlite, Postgres: $postgres]) 1789AC_MSG_NOTICE([NOTICE: Database support is set to MySQL: $mysql, SQLite: $sqlite, Postgres: $postgres])
1787 1790
1788if test "$enable_framework_build" = "yes" 1791if test "$enable_framework_build" = "yes"
1789then 1792then
1790 AC_MSG_NOTICE([NOTICE: Mac OS X framework build enabled.]) 1793 AC_MSG_NOTICE([Mac OS X framework build enabled.])
1791fi 1794fi
1792 1795
1793if test "x$install_nss" = "x0" 1796if test "x$install_nss" = "x0"
1794then 1797then
1795 AC_MSG_NOTICE([NOTICE: --with-sudo not specified and not running as 'root', will not install GNS NSS library]) 1798 AC_MSG_NOTICE([WARNING: Will not install GNS NSS library])
1796else 1799else
1797 AC_MSG_NOTICE([NOTICE: Will to install GNS NSS library to $NSS_DIR]) 1800 AC_MSG_NOTICE([NOTICE: Will install GNS NSS library to $NSS_DIR])
1798fi 1801fi
1799 1802
1800 1803