aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNils Gillmann <ng0@n0.is>2018-06-25 12:17:03 +0000
committerNils Gillmann <ng0@n0.is>2018-06-25 12:17:03 +0000
commit67669ed0c7f9472cb9018579cc0e4fe83a7de1cf (patch)
tree820a5be8afa70d2d708112d66b022c43e46abac6 /configure.ac
parent99060cca6a0244ec271e63537c3d2ff1a6c161ab (diff)
downloadgnunet-67669ed0c7f9472cb9018579cc0e4fe83a7de1cf.tar.gz
gnunet-67669ed0c7f9472cb9018579cc0e4fe83a7de1cf.zip
configure: Add initial upnpc code
Signed-off-by: Nils Gillmann <ng0@n0.is>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 20 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index fc44dcf5a..c8e316416 100644
--- a/configure.ac
+++ b/configure.ac
@@ -213,10 +213,19 @@ else
213AC_MSG_WARN([warning: 'iptables' not found.]) 213AC_MSG_WARN([warning: 'iptables' not found.])
214fi 214fi
215 215
216
217AC_CHECK_PROG(VAR_IFCONFIG_BINARY, ifconfig, true, false) 216AC_CHECK_PROG(VAR_IFCONFIG_BINARY, ifconfig, true, false)
218AC_MSG_WARN([warning: 'ifconfig' not found.]) 217AC_MSG_WARN([warning: 'ifconfig' not found.])
219 218
219# miniupnpc / upnpc binary is a soft runtime requirement
220AC_PATH_TARGET_TOOL(VAR_UPNPC_BINARY, upnpc, false)
221
222if test x"$VAR_UPNPC_BINARY" != x"false"
223then
224AC_DEFINE_UNQUOTED([UPNPC], "$VAR_UPNPC_BINARY", [Path to upnpc binary])
225else
226AC_MSG_WARN([warning: 'upnpc' binary not found.])
227fi
228
220AC_CHECK_MEMBER(struct tm.tm_gmtoff, 229AC_CHECK_MEMBER(struct tm.tm_gmtoff,
221 [AC_DEFINE(HAVE_TM_GMTOFF, 1, 230 [AC_DEFINE(HAVE_TM_GMTOFF, 1,
222 [Define if struct tm has the tm_gmtoff member.])], 231 [Define if struct tm has the tm_gmtoff member.])],
@@ -1811,6 +1820,10 @@ then
1811 AC_MSG_NOTICE([WARNING: jansson library not found. json support will not be compiled.]) 1820 AC_MSG_NOTICE([WARNING: jansson library not found. json support will not be compiled.])
1812fi 1821fi
1813 1822
1823#
1824# FIXME: `some modules' -> be more specific which exact modules.
1825#
1826
1814# warn user if iptables is not found 1827# warn user if iptables is not found
1815if test "$VAR_IPTABLES_BINARY" = "false" 1828if test "$VAR_IPTABLES_BINARY" = "false"
1816then 1829then
@@ -1823,6 +1836,12 @@ then
1823AC_MSG_NOTICE([WARNING: ifconfig not found. some modules may not have full functionality.]) 1836AC_MSG_NOTICE([WARNING: ifconfig not found. some modules may not have full functionality.])
1824fi 1837fi
1825 1838
1839# warn user if upnpc binary is not found
1840if test "$VAR_UPNPC_BINARY" = "false"
1841then
1842AC_MSG_NOTICE([WARNING: upnpc binary not found. some modules may not have full functionality.])
1843fi
1844
1826#gnutls 1845#gnutls
1827if test x$gnutls != xtrue 1846if test x$gnutls != xtrue
1828then 1847then