aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThien-Thi Nguyen <ttn@gnuvola.org>2021-11-20 01:41:02 -0500
committerThien-Thi Nguyen <ttn@gnuvola.org>2021-11-20 01:41:02 -0500
commit0390da9dd0920653c4e0c3c1ef17ab3ac65f8074 (patch)
tree37ac704b0d6eb401fd2677230cf0d6340ba0a853 /configure.ac
parentb04f9f7a72a4e6488eb688d6470bdc75e1da2987 (diff)
downloadgnunet-0390da9dd0920653c4e0c3c1ef17ab3ac65f8074.tar.gz
gnunet-0390da9dd0920653c4e0c3c1ef17ab3ac65f8074.zip
Convert indirect ‘AC_CHECK_FUNCS’ call to direct one
Later versions of Autoconf emit a warning about this. * configure.ac (funcstocheck): Convert shell var assignment to ‘AC_CHECK_FUNCS’ call. In later ‘AC_CHECK_FUNCS’ call, remove reference to ‘$funcstocheck’.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 0e1684400..f0db752c5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -102,7 +102,7 @@ CC_CHECK_CFLAG_APPEND([tautological-constant-out-of-range-compare])
102# Use Linux interface name unless the OS has a different preference 102# Use Linux interface name unless the OS has a different preference
103DEFAULT_INTERFACE="\"eth0\"" 103DEFAULT_INTERFACE="\"eth0\""
104 104
105funcstocheck="getnameinfo gethostname gethostbyname gethostbyaddr getaddrinfo getaddrinfo_a" 105AC_CHECK_FUNCS(getnameinfo gethostname gethostbyname gethostbyaddr getaddrinfo getaddrinfo_a)
106 106
107# Srcdir in a form that native compiler understands (i.e. DOS path on W32) 107# Srcdir in a form that native compiler understands (i.e. DOS path on W32)
108native_srcdir=$srcdir 108native_srcdir=$srcdir
@@ -1576,7 +1576,7 @@ AC_FUNC_VPRINTF
1576AC_HEADER_SYS_WAIT 1576AC_HEADER_SYS_WAIT
1577AC_TYPE_OFF_T 1577AC_TYPE_OFF_T
1578AC_TYPE_UID_T 1578AC_TYPE_UID_T
1579AC_CHECK_FUNCS(atoll stat64 strnlen mremap getrlimit setrlimit sysconf initgroups strndup gethostbyname2 getpeerucred getpeereid setresuid $funcstocheck getifaddrs freeifaddrs getresgid mallinfo malloc_size malloc_usable_size getrusage random srandom stat statfs statvfs wait4 timegm) 1579AC_CHECK_FUNCS(atoll stat64 strnlen mremap getrlimit setrlimit sysconf initgroups strndup gethostbyname2 getpeerucred getpeereid setresuid getifaddrs freeifaddrs getresgid mallinfo malloc_size malloc_usable_size getrusage random srandom stat statfs statvfs wait4 timegm)
1580 1580
1581# restore LIBS 1581# restore LIBS
1582LIBS=$SAVE_LIBS 1582LIBS=$SAVE_LIBS