aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2015-05-28 09:02:31 +0000
committerChristian Grothoff <christian@grothoff.org>2015-05-28 09:02:31 +0000
commit078f7063aef1d4105e71160b8764ab95c2dcdfbe (patch)
tree86d498356ceaaa1ba738f64a158cce2cd0163a15 /configure.ac
parent9469cd334f29ca9437e13eb951b53b7690f10be9 (diff)
downloadgnunet-078f7063aef1d4105e71160b8764ab95c2dcdfbe.tar.gz
gnunet-078f7063aef1d4105e71160b8764ab95c2dcdfbe.zip
adding --enable-taler-wallet configure option to build a reduced version of libgnunetutil with only the parts needed by GNU Taler wallets
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6495cc628..53bb114b7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -546,6 +546,21 @@ fi
546AC_CHECK_LIB([kvm],[kvm_open]) 546AC_CHECK_LIB([kvm],[kvm_open])
547AC_CHECK_LIB([kstat],[kstat_open]) 547AC_CHECK_LIB([kstat],[kstat_open])
548 548
549
550# should experimental code be compiled (code that may not yet compile)?
551AC_MSG_CHECKING(whether to compile GNU Taler Wallet library ONLY)
552AC_ARG_ENABLE([taler-wallet],
553 [AS_HELP_STRING([--taler-wallet], [only compile for Taler wallet])],
554 [taler_only=${enableval}],
555 [taler_only=no])
556AC_MSG_RESULT($taler_only)
557AM_CONDITIONAL([TALER_ONLY], [test "x$taler_only" = "xyes"])
558
559if test "$taler_only" != yes
560then
561
562
563
549# test for libextractor 564# test for libextractor
550extractor=0 565extractor=0
551AC_MSG_CHECKING(for libextractor) 566AC_MSG_CHECKING(for libextractor)
@@ -581,6 +596,7 @@ fi
581# restore LIBS 596# restore LIBS
582LIBS=$SAVE_LIBS 597LIBS=$SAVE_LIBS
583 598
599
584# Check for libltdl header (#2999) 600# Check for libltdl header (#2999)
585ltdl=0 601ltdl=0
586AC_MSG_CHECKING(for libltdl) 602AC_MSG_CHECKING(for libltdl)
@@ -618,6 +634,8 @@ fi
618# restore LIBS 634# restore LIBS
619LIBS=$SAVE_LIBS 635LIBS=$SAVE_LIBS
620 636
637fi
638
621# test for libunistring 639# test for libunistring
622gl_LIBUNISTRING 640gl_LIBUNISTRING
623if test $HAVE_LIBUNISTRING != yes; then 641if test $HAVE_LIBUNISTRING != yes; then