summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSree Harsha Totakura <totakura@in.tum.de>2012-11-30 16:56:39 +0000
committerSree Harsha Totakura <totakura@in.tum.de>2012-11-30 16:56:39 +0000
commit10460200168c53be3573c0761a6a0705b08ea5cb (patch)
treefbe2abba16aad2efafc9ce64c6a871ed0f7fd56a /configure.ac
parent90c0da922d6eb9407bf6f3215a8803f5f192cb42 (diff)
configure option for using IBM LoadLeveler for scheduling testbed slaves on SuperMUC
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac31
1 files changed, 31 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 97fb33b71..c70c22292 100644
--- a/configure.ac
+++ b/configure.ac
@@ -936,6 +936,37 @@ AM_CONDITIONAL(HAVE_GNUTLS, test x$gnutls = xtrue)
AC_DEFINE_UNQUOTED([HAVE_GNUTLS], $gnutls, [We have gnutls])
+# Test if we are building for superMUC
+llapi=0
+AC_MSG_CHECKING(if testbed should use IBM LoadLeveler to run on SuperMUC)
+AC_ARG_WITH([ll],
+ [AS_HELP_STRING([--with-ll=PFX],
+ [use IBM LoadLeveler (installed at PFX) for running testbed on SuperMUC]. Default is no)],
+ [AC_MSG_RESULT([$with_ll])
+ case $with_ll in
+ no)
+ ;;
+ yes)
+ AC_CHECK_HEADERS([llapi.h],
+ AC_CHECK_LIB([llapi], [llsubmit],
+ llapi=true,
+ AC_MSG_ERROR(libllapi not found but --with-llapi given)),
+ AC_MSG_ERROR(llapi.h not found but --with-llapi given))
+ ;;
+ *)
+ LDFLAGS="-L$with_ll/lib $LDFLAGS"
+ CPPFLAGS="-I$with_ll/include $CPPFLAGS"
+ AC_CHECK_HEADERS([llapi.h],
+ AC_CHECK_LIB([llapi], [llsubmit],
+ llapi=true,
+ AC_MSG_ERROR(libllapi not found but --with-llapi given)),
+ AC_MSG_ERROR(llapi.h not found but --with-llapi given))
+ ;;
+ esac
+ ],
+ [AC_MSG_RESULT(--with-ll not specified)])
+AM_CONDITIONAL(WITH_LL, test x$llapi = xtrue)
+AC_DEFINE_UNQUOTED(WITH_LL, $llapi, [Do we have to use IBM LoadLeveler])
# should 'make check' run tests?
AC_MSG_CHECKING(whether to run tests)