aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMartin Schanzenbach <mschanzenbach@posteo.de>2015-10-11 09:27:47 +0000
committerMartin Schanzenbach <mschanzenbach@posteo.de>2015-10-11 09:27:47 +0000
commit15f13cc7f9b59269a8b5ee8c750b5729b2c359ae (patch)
treed0689fa0c056ae7a56beffb1a36140a79d771c9b /configure.ac
parent2d6f7ad88e58cea86852bbe798a425ef8ac8cb3e (diff)
downloadgnunet-15f13cc7f9b59269a8b5ee8c750b5729b2c359ae.tar.gz
gnunet-15f13cc7f9b59269a8b5ee8c750b5729b2c359ae.zip
- implicitly enable rest functions in experimental if jansson.h present
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 10 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index baf7a5517..f1a30ead2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -382,6 +382,16 @@ else
382 AC_DEFINE([HAVE_LIBBLUETOOTH],[0],[Lacking bluetooth library]) 382 AC_DEFINE([HAVE_LIBBLUETOOTH],[0],[Lacking bluetooth library])
383fi 383fi
384 384
385# check for jansson library
386jansson=0
387AC_CHECK_HEADER([jansson.h],jansson=1)
388AM_CONDITIONAL(HAVE_REST, [test "$jansson" = 1])
389if test "$jansson" = 1
390then
391 AC_DEFINE([HAVE_REST],[1],[Have jansson library])
392else
393 AC_DEFINE([HAVE_REST],[0],[Lacking jansson library])
394fi
385 395
386# check for libpulse(audio) library 396# check for libpulse(audio) library
387pulse=0 397pulse=0
@@ -1288,15 +1298,6 @@ AC_ARG_ENABLE([wachs],
1288AC_MSG_RESULT($enable_wachs) 1298AC_MSG_RESULT($enable_wachs)
1289AM_CONDITIONAL([HAVE_WACHS], [test "x$enable_wachs" = "xyes"]) 1299AM_CONDITIONAL([HAVE_WACHS], [test "x$enable_wachs" = "xyes"])
1290 1300
1291# REST API
1292AC_MSG_CHECKING(whether to compile REST API)
1293AC_ARG_ENABLE([rest],
1294 [AS_HELP_STRING([--enable-rest], [enable REST])],
1295 [enable_rest=${enableval}],
1296 [enable_rest=no])
1297AC_MSG_RESULT($enable_rest)
1298AM_CONDITIONAL([HAVE_REST], [test "x$enable_rest" = "xyes"])
1299
1300# should malicious code be compiled (should only be used for testing)? 1301# should malicious code be compiled (should only be used for testing)?
1301AC_MSG_CHECKING(whether to compile malicious code) 1302AC_MSG_CHECKING(whether to compile malicious code)
1302AC_ARG_ENABLE([malicious], 1303AC_ARG_ENABLE([malicious],