aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorng0 <ng0@n0.is>2019-04-01 18:00:45 +0000
committerng0 <ng0@n0.is>2019-04-01 18:00:45 +0000
commit1d17d1aa2e32586ac07f637ad320b05a56cc1e3c (patch)
treee030be42a89ae6f1b0c7b1651ebbf0778cbe1763 /configure.ac
parent9662ba32e6b383fc7033f5aceb070ee49ec39d09 (diff)
parent8e50f39a2c1ba03011bd1e5c51d0721f220e2e7a (diff)
downloadgnunet-1d17d1aa2e32586ac07f637ad320b05a56cc1e3c.tar.gz
gnunet-1d17d1aa2e32586ac07f637ad320b05a56cc1e3c.zip
Merge branch 'dev/ng0/5673_5616'
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c23845b97..270011a1c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -376,6 +376,21 @@ else
376 AC_DEFINE([DOCUMENTATION_ONLY],[0],[Not building only the documentation]) 376 AC_DEFINE([DOCUMENTATION_ONLY],[0],[Not building only the documentation])
377fi 377fi
378 378
379# should the build process be including the manpages? (default: yes)
380AC_MSG_CHECKING(whether to include man pages)
381AC_ARG_ENABLE([include-manpages],
382 [AS_HELP_STRING([--disable-include-manpages], [Do not include the man pages in build and installation])],
383 [include_manpages=${enableval}],
384 [include_manpages=yes])
385AC_MSG_RESULT($include_manpages)
386if test "x$include_manpages" = "xyes"
387then
388 AM_CONDITIONAL([INCLUDE_MANPAGES],true)
389 AC_DEFINE([INCLUDE_MANPAGES],[1],[Including the man pages in the build and installation])
390else
391 AM_CONDITIONAL([INCLUDE_MANPAGES],false)
392 AC_DEFINE([INCLUDE_MANPAGES],[0],[Not including the man pages in the build and installation])
393fi
379 394
380# Adam shostack suggests the following for Windows: 395# Adam shostack suggests the following for Windows:
381# -D_FORTIFY_SOURCE=2 -fstack-protector-all 396# -D_FORTIFY_SOURCE=2 -fstack-protector-all
@@ -1327,6 +1342,7 @@ DATAROOTDIR=$datarootdir
1327AC_SUBST(DATAROOTDIR) 1342AC_SUBST(DATAROOTDIR)
1328 1343
1329# test for sudo 1344# test for sudo
1345# TODO: do we need to change anything for "doas" on openbsd?
1330AC_MSG_CHECKING(for sudo) 1346AC_MSG_CHECKING(for sudo)
1331AC_ARG_WITH(sudo, 1347AC_ARG_WITH(sudo,
1332 [ --with-sudo=PATH path to sudo binary (or just yes)], 1348 [ --with-sudo=PATH path to sudo binary (or just yes)],