aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSree Harsha Totakura <totakura@in.tum.de>2013-10-12 00:07:33 +0000
committerSree Harsha Totakura <totakura@in.tum.de>2013-10-12 00:07:33 +0000
commit27728a48d661e9ee546cc95aae8fa52050eefb29 (patch)
tree89450fc22b530dc592134ac18405180eeafe13b3 /configure.ac
parent6d38e5b12b460d1d7f0a6eafe1410f7121e04002 (diff)
downloadgnunet-27728a48d661e9ee546cc95aae8fa52050eefb29.tar.gz
gnunet-27728a48d661e9ee546cc95aae8fa52050eefb29.zip
- change --enable-ll to --enable-supermuc
- define a system wide termination signal GNUNET_TERM_SIG. Set this to SIGUSR1 only when building for SuperMUC
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 12 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index 2e191abf3..2e0bda700 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1036,22 +1036,21 @@ AC_DEFINE_UNQUOTED([HAVE_GNUTLS], $gnutls, [We have gnutls])
1036 1036
1037 1037
1038# Test if we are building for superMUC 1038# Test if we are building for superMUC
1039AC_MSG_CHECKING(if testbed should use IBM LoadLeveler to run on SuperMUC) 1039AC_MSG_CHECKING(if GNUnet is being configured to run on the SuperMUC)
1040AC_ARG_ENABLE([ll], 1040AC_ARG_ENABLE([supermuc],
1041 [AS_HELP_STRING([--enable-ll], 1041 [AS_HELP_STRING([--enable-supermuc],
1042 [build GNUnet testbed for use with IBM LoadLeveler for running testbed on 1042 [build GNUnet with support to run on the SuperMUC (default is NO)])],
1043 SuperMUC (default is NO)])], 1043 [if test "x$enable_supermuc" = "xno"
1044 [if test "x$enable_ll" = "xno"
1045 then 1044 then
1046 ll=0 1045 supermuc=0
1047 else 1046 else
1048 ll=1 1047 supermuc=1
1049 fi], 1048 fi],
1050 [ll=0 1049 [supermuc=0
1051 enable_ll=no]) 1050 enable_supermuc=no])
1052AC_MSG_RESULT($enable_ll) 1051AC_MSG_RESULT($enable_SUPERMUC)
1053AM_CONDITIONAL([ENABLE_LL], [test "x$ll" = "x1"]) 1052AM_CONDITIONAL([ENABLE_SUPERMUC], [test "x$supermuc" = "x1"])
1054AC_DEFINE_UNQUOTED([ENABLE_LL], [$ll], [Build with LL support]) 1053AC_DEFINE_UNQUOTED([ENABLE_SUPERMUC], [$supermuc], [Build with support for SuperMUC])
1055 1054
1056# Check if NSE has to send timestamp information to testbed logger for 1055# Check if NSE has to send timestamp information to testbed logger for
1057# generating histogram of messages received 1056# generating histogram of messages received