aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSchanzenbach, Martin <mschanzenbach@posteo.de>2017-06-23 20:39:27 +0200
committerSchanzenbach, Martin <mschanzenbach@posteo.de>2017-06-23 20:39:27 +0200
commit2d81d6d8217b9aa08139bd66d14c597705568920 (patch)
tree197017d2b8498a79700ef6e00160b80ae749222e /configure.ac
parentad5b64d8ef992d7281501297b547095569d8f0fb (diff)
parentd7547ab18052726a69ee088876389a18798e03a8 (diff)
downloadgnunet-2d81d6d8217b9aa08139bd66d14c597705568920.tar.gz
gnunet-2d81d6d8217b9aa08139bd66d14c597705568920.zip
Merge remote-tracking branch 'origin/master' into credentials
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac59
1 files changed, 30 insertions, 29 deletions
diff --git a/configure.ac b/configure.ac
index 76f627597..8a2ab9262 100644
--- a/configure.ac
+++ b/configure.ac
@@ -71,7 +71,7 @@ case "$host_os" in
71 AC_DEFINE_UNQUOTED(DARWIN,1,[This is an Apple Darwin system]) 71 AC_DEFINE_UNQUOTED(DARWIN,1,[This is an Apple Darwin system])
72 CPPFLAGS="-D_APPLE_C_SOURCE $CPPFLAGS" 72 CPPFLAGS="-D_APPLE_C_SOURCE $CPPFLAGS"
73 CFLAGS="-fno-common $CFLAGS" 73 CFLAGS="-fno-common $CFLAGS"
74 AC_MSG_WARN([The VPN application cannot be compiled on your OS]) 74 AC_MSG_WARN([WARNING: The VPN application cannot be compiled on your OS])
75 build_target="darwin" 75 build_target="darwin"
76 DEFAULT_INTERFACE="\"en0\"" 76 DEFAULT_INTERFACE="\"en0\""
77 LIBPREFIX= 77 LIBPREFIX=
@@ -522,7 +522,7 @@ then
522 AM_CONDITIONAL(HAVE_LIBCURL, false) 522 AM_CONDITIONAL(HAVE_LIBCURL, false)
523if test "$gnurl" = 0 523if test "$gnurl" = 0
524then 524then
525 AC_MSG_WARN([GNUnet requires libcurl-gnutls or gnurl >= 7.34]) 525 AC_MSG_WARN([ERROR: GNUnet requires libcurl-gnutls or gnurl >= 7.34])
526fi 526fi
527else 527else
528 AM_CONDITIONAL(HAVE_LIBCURL, true) 528 AM_CONDITIONAL(HAVE_LIBCURL, true)
@@ -542,19 +542,18 @@ AC_CHECK_MEMBERS(glp_iocp.presolve,,[gplk=false],[[#include <glpk.h>]])
542if test x$gplk = xfalse 542if test x$gplk = xfalse
543then 543then
544 AM_CONDITIONAL(HAVE_LIBGLPK, false) 544 AM_CONDITIONAL(HAVE_LIBGLPK, false)
545 AC_MSG_WARN([GNUnet requires GLPK >= 4.32]) 545 AC_MSG_WARN([ERROR: GNUnet requires GLPK >= 4.32])
546else 546else
547 AM_CONDITIONAL(HAVE_LIBGLPK, true) 547 AM_CONDITIONAL(HAVE_LIBGLPK, true)
548 AC_DEFINE([HAVE_LIBGLPK],[1],[Have GLPK]) 548 AC_DEFINE([HAVE_LIBGLPK],[1],[Have GLPK])
549fi 549fi
550 550
551 551
552
553AC_CHECK_HEADERS([nss.h],[nss=true],[nss=false]) 552AC_CHECK_HEADERS([nss.h],[nss=true],[nss=false])
554if test x$nss = xfalse 553if test x$nss = xfalse
555then 554then
556 AM_CONDITIONAL(HAVE_GLIBCNSS, false) 555 AM_CONDITIONAL(HAVE_GLIBCNSS, false)
557 AC_MSG_WARN([No GNU libc nss header, will not build NSS plugin]) 556 AC_MSG_WARN([ERROR: No GNU libc nss header, will not build NSS plugin])
558else 557else
559 AM_CONDITIONAL(HAVE_GLIBCNSS, true) 558 AM_CONDITIONAL(HAVE_GLIBCNSS, true)
560fi 559fi
@@ -1138,16 +1137,20 @@ AC_ARG_WITH(nssdir,
1138 esac 1137 esac
1139 ], 1138 ],
1140 [ 1139 [
1141 if test "x$SUDO_BINARY" != "x" -o -w / 1140# This test is inappropriate when installation with DESTDIR is
1142 then 1141# run much later and uid will be root when needed. Enabling this
1142# code breaks the gnunet.ebuild for gentoo.
1143#
1144# if test "x$SUDO_BINARY" != "x" -o -w /
1145# then
1143 NSS_DIR="/lib" 1146 NSS_DIR="/lib"
1144 install_nss=1 1147 install_nss=1
1145 AC_MSG_RESULT([yes, to /lib]) 1148 AC_MSG_RESULT([yes, to /lib])
1146 else 1149# else
1147 NSS_DIR= 1150# NSS_DIR=
1148 install_nss=0 1151# install_nss=0
1149 AC_MSG_RESULT([no]) 1152# AC_MSG_RESULT([no])
1150 fi 1153# fi
1151 ]) 1154 ])
1152AC_SUBST(NSS_DIR) 1155AC_SUBST(NSS_DIR)
1153AM_CONDITIONAL([INSTALL_NSS], [test "x$install_nss" != "x0"]) 1156AM_CONDITIONAL([INSTALL_NSS], [test "x$install_nss" != "x0"])
@@ -1612,7 +1615,6 @@ src/peerinfo-tool/Makefile
1612src/peerstore/Makefile 1615src/peerstore/Makefile
1613src/peerstore/peerstore.conf 1616src/peerstore/peerstore.conf
1614src/pq/Makefile 1617src/pq/Makefile
1615src/postgres/Makefile
1616src/psycutil/Makefile 1618src/psycutil/Makefile
1617src/psyc/Makefile 1619src/psyc/Makefile
1618src/psyc/psyc.conf 1620src/psyc/psyc.conf
@@ -1683,7 +1685,6 @@ pkgconfig/gnunetnat.pc
1683pkgconfig/gnunetnse.pc 1685pkgconfig/gnunetnse.pc
1684pkgconfig/gnunetpeerinfo.pc 1686pkgconfig/gnunetpeerinfo.pc
1685pkgconfig/gnunetpq.pc 1687pkgconfig/gnunetpq.pc
1686pkgconfig/gnunetpostgres.pc
1687pkgconfig/gnunetpsyc.pc 1688pkgconfig/gnunetpsyc.pc
1688pkgconfig/gnunetpsycstore.pc 1689pkgconfig/gnunetpsycstore.pc
1689pkgconfig/gnunetregex.pc 1690pkgconfig/gnunetregex.pc
@@ -1708,7 +1709,7 @@ AC_OUTPUT
1708# warn user if mysql found but not used due to version 1709# warn user if mysql found but not used due to version
1709if test "$mysqlfail" = "true" 1710if test "$mysqlfail" = "true"
1710then 1711then
1711 AC_MSG_NOTICE([NOTICE: MySQL found, but too old. MySQL support will not be compiled.]) 1712 AC_MSG_NOTICE([WARNING: MySQL found, but too old. MySQL support will not be compiled.])
1712fi 1713fi
1713 1714
1714# sqlite 1715# sqlite
@@ -1722,7 +1723,7 @@ if test "$gnurl" = "0"
1722then 1723then
1723 if test "x$curl" = "xfalse" 1724 if test "x$curl" = "xfalse"
1724 then 1725 then
1725 AC_MSG_NOTICE([NOTICE: libgnurl not found. http client support will not be compiled.]) 1726 AC_MSG_NOTICE([WARNING: libgnurl not found. http client support will not be compiled.])
1726 AC_MSG_WARN([ERROR: libgnurl not found. hostlist daemon will not be compiled, and you probably WANT the hostlist daemon]) 1727 AC_MSG_WARN([ERROR: libgnurl not found. hostlist daemon will not be compiled, and you probably WANT the hostlist daemon])
1727 else 1728 else
1728 AC_MSG_NOTICE([WARNING: libgnurl not found, trying to use libcurl-gnutls instead.]) 1729 AC_MSG_NOTICE([WARNING: libgnurl not found, trying to use libcurl-gnutls instead.])
@@ -1733,36 +1734,36 @@ fi
1733# bluetooth 1734# bluetooth
1734if test "x$bluetooth" = "x0" 1735if test "x$bluetooth" = "x0"
1735then 1736then
1736 AC_MSG_NOTICE([NOTICE: bluetooth library not found. bluetooth support will not be compiled.]) 1737 AC_MSG_NOTICE([WARNING: bluetooth library not found. bluetooth support will not be compiled.])
1737fi 1738fi
1738 1739
1739# jansson 1740# jansson
1740if test "x$jansson" = "x0" 1741if test "x$jansson" = "x0"
1741then 1742then
1742 AC_MSG_NOTICE([NOTICE: jansson library not found. json support will not be compiled.]) 1743 AC_MSG_NOTICE([WARNING: jansson library not found. json support will not be compiled.])
1743fi 1744fi
1744 1745
1745#gnutls 1746#gnutls
1746if test x$gnutls != xtrue 1747if test x$gnutls != xtrue
1747then 1748then
1748 AC_MSG_NOTICE([NOTICE: GnuTLS not found, gnunet-gns-proxy will not be built]) 1749 AC_MSG_NOTICE([WARNING: GnuTLS not found, gnunet-gns-proxy will not be built])
1749else 1750else
1750if test "x$gnutls_dane" != "x1" 1751if test "x$gnutls_dane" != "x1"
1751then 1752then
1752 AC_MSG_NOTICE([NOTICE: GnuTLS has no DANE support, DANE validation will not be possible]) 1753 AC_MSG_NOTICE([WARNING: GnuTLS has no DANE support, DANE validation will not be possible])
1753fi 1754fi
1754fi 1755fi
1755 1756
1756# java ports 1757# java ports
1757if test "x$enable_java_ports" = "xyes" 1758if test "x$enable_java_ports" = "xyes"
1758then 1759then
1759 AC_MSG_NOTICE([NOTICE: opening ports for gnunet-java bindings by default.]) 1760 AC_MSG_NOTICE([NOTICE: Opening ports for gnunet-java bindings by default.])
1760fi 1761fi
1761 1762
1762# MHD 1763# MHD
1763if test "x$lmhd" != "x1" 1764if test "x$lmhd" != "x1"
1764then 1765then
1765 AC_MSG_NOTICE([NOTICE: libmicrohttpd not found, http transport will not be installed.]) 1766 AC_MSG_NOTICE([WARNING: libmicrohttpd not found, http transport will not be installed.])
1766fi 1767fi
1767 1768
1768# conversation 1769# conversation
@@ -1770,35 +1771,35 @@ if test "x$conversation_backend" = "xnone"
1770then 1771then
1771 if test "x$pulse" != "x1" 1772 if test "x$pulse" != "x1"
1772 then 1773 then
1773 AC_MSG_NOTICE([NOTICE: libpulse(audio) not found, conversation will not be built.]) 1774 AC_MSG_NOTICE([WARNING: libpulse(audio) not found, conversation will not be built.])
1774 fi 1775 fi
1775 if test "x$opus" != "x1" 1776 if test "x$opus" != "x1"
1776 then 1777 then
1777 AC_MSG_NOTICE([NOTICE: libopus not found, conversation will not be built.]) 1778 AC_MSG_NOTICE([WARNING: libopus not found, conversation will not be built.])
1778 fi 1779 fi
1779 if test "x$gst" != "x1" 1780 if test "x$gst" != "x1"
1780 then 1781 then
1781 AC_MSG_NOTICE([NOTICE: GStreamer not found, conversation will not be built.]) 1782 AC_MSG_NOTICE([WARNING: GStreamer not found, conversation will not be built.])
1782 fi 1783 fi
1783fi 1784fi
1784 1785
1785if test "$extractor" != 1 1786if test "$extractor" != 1
1786then 1787then
1787 AC_MSG_WARN([NOTICE: libextractor not found, but various file-sharing functions require it]) 1788 AC_MSG_WARN([ERROR: libextractor not found, but various file-sharing functions require it])
1788fi 1789fi
1789 1790
1790AC_MSG_NOTICE([NOTICE: Database support is set to MySQL: $mysql, SQLite: $sqlite, Postgres: $postgres]) 1791AC_MSG_NOTICE([NOTICE: Database support is set to MySQL: $mysql, SQLite: $sqlite, Postgres: $postgres])
1791 1792
1792if test "$enable_framework_build" = "yes" 1793if test "$enable_framework_build" = "yes"
1793then 1794then
1794 AC_MSG_NOTICE([NOTICE: Mac OS X framework build enabled.]) 1795 AC_MSG_NOTICE([Mac OS X framework build enabled.])
1795fi 1796fi
1796 1797
1797if test "x$install_nss" = "x0" 1798if test "x$install_nss" = "x0"
1798then 1799then
1799 AC_MSG_NOTICE([NOTICE: --with-sudo not specified and not running as 'root', will not install GNS NSS library]) 1800 AC_MSG_NOTICE([WARNING: Will not install GNS NSS library])
1800else 1801else
1801 AC_MSG_NOTICE([NOTICE: Will to install GNS NSS library to $NSS_DIR]) 1802 AC_MSG_NOTICE([NOTICE: Will install GNS NSS library to $NSS_DIR])
1802fi 1803fi
1803 1804
1804 1805