aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2012-06-11 09:54:25 +0000
committerChristian Grothoff <christian@grothoff.org>2012-06-11 09:54:25 +0000
commit3594020243f21a0fd7c5259a9706e88865844caf (patch)
treebdde10e36b22cc70322e22f38d5e28eb5168454e /configure.ac
parentf13aa4cbd76d7aaf5070b1762c61c47fa7517842 (diff)
downloadgnunet-3594020243f21a0fd7c5259a9706e88865844caf.tar.gz
gnunet-3594020243f21a0fd7c5259a9706e88865844caf.zip
adding check for gnutls
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac41
1 files changed, 41 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e711a12a9..de4817a0c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -808,6 +808,40 @@ AC_ARG_WITH(gnunetdns,
808AC_SUBST(GNUNETDNS_GROUP) 808AC_SUBST(GNUNETDNS_GROUP)
809 809
810 810
811
812# gnutls
813gnutls=0
814AC_MSG_CHECKING(for gnutls)
815AC_ARG_WITH(gnutls,
816 [ --with-gnutls=PFX base of gnutls installation],
817 [AC_MSG_RESULT([$with_gnutls])
818 case $with_gnutls in
819 no)
820 ;;
821 yes)
822 AC_CHECK_HEADERS([gnutls/abstract.h],
823 AC_CHECK_LIB([gnutls], [gnutls_priority_set],
824 gnutls=true))
825 ;;
826 *)
827 LDFLAGS="-L$with_gnutls/lib $LDFLAGS"
828 CPPFLAGS="-I$with_gnutls/include $CPPFLAGS"
829 AC_CHECK_HEADERS([gnutls/abstract.h],
830 AC_CHECK_LIB([gnutls], [gnutls_priority_set],
831 EXT_LIB_PATH="-L$with_gnutls/lib $EXT_LIB_PATH"
832 gnutls=true))
833 ;;
834 esac
835 ],
836 [AC_MSG_RESULT([--with-gnutls not specified])
837 AC_CHECK_HEADERS([gnutls/abstract.h],
838 AC_CHECK_LIB([gnutls], [gnutls_priority_set],
839 gnutls=true))])
840AM_CONDITIONAL(HAVE_GNUTLS, test x$gnutls = xtrue)
841AC_DEFINE_UNQUOTED([HAVE_GNUTLS], $gnutls, [We have gnutls])
842
843
844
811# should 'make check' run tests? 845# should 'make check' run tests?
812AC_MSG_CHECKING(whether to run tests) 846AC_MSG_CHECKING(whether to run tests)
813AC_ARG_ENABLE([testruns], 847AC_ARG_ENABLE([testruns],
@@ -1105,6 +1139,12 @@ then
1105 AC_MSG_NOTICE([NOTICE: sqlite not found. sqLite support will not be compiled.]) 1139 AC_MSG_NOTICE([NOTICE: sqlite not found. sqLite support will not be compiled.])
1106fi 1140fi
1107 1141
1142#gnutls
1143if test x$gnutls != xtrue
1144then
1145 AC_MSG_NOTICE([NOTICE: gnutls not found, gnunet-gns-proxy will not be built])
1146fi
1147
1108# java ports 1148# java ports
1109if test "x$enable_java_ports" = "xyes" 1149if test "x$enable_java_ports" = "xyes"
1110then 1150then
@@ -1128,6 +1168,7 @@ then
1128 AC_MSG_NOTICE([NOTICE: --with-sudo not specified and not running as 'root', will not install GNS NSS library]) 1168 AC_MSG_NOTICE([NOTICE: --with-sudo not specified and not running as 'root', will not install GNS NSS library])
1129fi 1169fi
1130 1170
1171
1131AC_MSG_NOTICE([******************************************** 1172AC_MSG_NOTICE([********************************************
1132You can compile GNUnet with 1173You can compile GNUnet with
1133 make 1174 make