summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2010-10-02 13:58:26 +0000
committerChristian Grothoff <christian@grothoff.org>2010-10-02 13:58:26 +0000
commit3b54e87cfe8f36ce11af703bae138a3a0a828e8a (patch)
treefd6a61aabfd01f4115d8e549efc7c7bae9f3687c /configure.ac
parent7b80cc15aaf3f61fb05635577fdd5258d5b8bb17 (diff)
new configure flag to enable 'malicious' test code
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 22133e07d..b958efc7e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -725,6 +725,18 @@ AC_ARG_ENABLE(experimental,
AC_MSG_RESULT($enable_experimental)
AM_CONDITIONAL([HAVE_EXPERIMENTAL], [test "x$enable_experimental" = "xyes"])
+# should malicious code be compiled (code used for testing with malicious peers)
+disable_malicious=yes
+AC_MSG_CHECKING(whether to compile malicious code)
+AC_ARG_ENABLE(malicious,
+ [AS_HELP_STRING([--enable-malicious],
+ [enable compiling malicious code (only for developers for testing)])],
+ [enable_malicious=$enableval],
+ [enable_malicious="no"])
+AC_MSG_RESULT($enable_malicious)
+AM_CONDITIONAL([HAVE_MALICIOUS], [test "x$enable_malicious" = "xyes"])
+AC_DEFINE_UNQUOTED([HAVE_MALICIOUS], $enable_malicious, [Compile malicious code])
+
# gcov compilation
use_gcov=no
AC_ARG_ENABLE([coverage], AS_HELP_STRING([--enable-coverage],