aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2010-01-03 21:42:52 +0000
committerChristian Grothoff <christian@grothoff.org>2010-01-03 21:42:52 +0000
commit3c5249af8087b0b1a4f131a3e19a9759639ab5db (patch)
tree697ff622324a7d259dc59da63205f398661a56fa /configure.ac
parentebd1325d27e2062f3fb8e92766178ab0660c2dac (diff)
downloadgnunet-3c5249af8087b0b1a4f131a3e19a9759639ab5db.tar.gz
gnunet-3c5249af8087b0b1a4f131a3e19a9759639ab5db.zip
adapting main code base to work with libextractor 0.6 API; testcases will follow later
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 5 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 4a87c0067..41157ca29 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,5 @@
1# This file is part of GNUnet. 1# This file is part of GNUnet.
2# (C) 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009 Christian Grothoff (and other contributing authors) 2# (C) 2001--2010 Christian Grothoff (and other contributing authors)
3# 3#
4# GNUnet is free software; you can redistribute it and/or modify 4# GNUnet is free software; you can redistribute it and/or modify
5# it under the terms of the GNU General Public License as published 5# it under the terms of the GNU General Public License as published
@@ -38,7 +38,6 @@ AC_PROG_INSTALL
38AC_PROG_LN_S 38AC_PROG_LN_S
39AC_PROG_MAKE_SET 39AC_PROG_MAKE_SET
40AM_PROG_CC_C_O 40AM_PROG_CC_C_O
41LT_CONFIG_LTDL_DIR([libltdl])
42AC_CANONICAL_HOST 41AC_CANONICAL_HOST
43LT_INIT([disable-static dlopen win32-dll]) 42LT_INIT([disable-static dlopen win32-dll])
44LTDL_INIT 43LTDL_INIT
@@ -141,7 +140,7 @@ netbsd*)
141 AC_CHECK_LIB(intl, gettext) 140 AC_CHECK_LIB(intl, gettext)
142 LDFLAGS="$LDFLAGS -no-undefined -Wl,--export-all-symbols" 141 LDFLAGS="$LDFLAGS -no-undefined -Wl,--export-all-symbols"
143 LIBS="$LIBS -lws2_32 -lplibc" 142 LIBS="$LIBS -lws2_32 -lplibc"
144 CFLAGS="-mms-bitfields -I../../libltdl $CFLAGS" 143 CFLAGS="-mms-bitfields $CFLAGS"
145 build_target="mingw" 144 build_target="mingw"
146 AC_PROG_CXX 145 AC_PROG_CXX
147 LIBPREFIX=lib 146 LIBPREFIX=lib
@@ -212,14 +211,14 @@ AC_ARG_WITH(extractor,
212 ;; 211 ;;
213 yes) 212 yes)
214 AC_CHECK_HEADERS(extractor.h, 213 AC_CHECK_HEADERS(extractor.h,
215 AC_CHECK_LIB([extractor], [EXTRACTOR_loadDefaultLibraries], 214 AC_CHECK_LIB([extractor], [EXTRACTOR_plugin_add_defaults],
216 extractor=1)) 215 extractor=1))
217 ;; 216 ;;
218 *) 217 *)
219 LDFLAGS="-L$with_extractor/lib $LDFLAGS" 218 LDFLAGS="-L$with_extractor/lib $LDFLAGS"
220 CPPFLAGS="-I$with_extractor/include $CPPFLAGS" 219 CPPFLAGS="-I$with_extractor/include $CPPFLAGS"
221 AC_CHECK_HEADERS(extractor.h, 220 AC_CHECK_HEADERS(extractor.h,
222 AC_CHECK_LIB([extractor], [EXTRACTOR_loadDefaultLibraries], 221 AC_CHECK_LIB([extractor], [EXTRACTOR_plugin_add_defaults],
223 EXT_LIB_PATH="-L$with_extractor/lib $EXT_LIB_PATH" 222 EXT_LIB_PATH="-L$with_extractor/lib $EXT_LIB_PATH"
224 extractor=1)) 223 extractor=1))
225 ;; 224 ;;
@@ -227,7 +226,7 @@ AC_ARG_WITH(extractor,
227 ], 226 ],
228 [AC_MSG_RESULT([--with-extractor not specified]) 227 [AC_MSG_RESULT([--with-extractor not specified])
229 AC_CHECK_HEADERS(extractor.h, 228 AC_CHECK_HEADERS(extractor.h,
230 AC_CHECK_LIB([extractor], [EXTRACTOR_loadDefaultLibraries], 229 AC_CHECK_LIB([extractor], [EXTRACTOR_plugin_add_defaults],
231 extractor=1))]) 230 extractor=1))])
232if test "$extractor" != 1 231if test "$extractor" != 1
233then 232then