aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2012-10-12 15:32:08 +0000
committerChristian Grothoff <christian@grothoff.org>2012-10-12 15:32:08 +0000
commit4f7742c31bcf64550dae6a14d6b6da54d6d57e59 (patch)
tree3eaf2f4c2f1272e817a4d23d1b642a16ae0bce05 /configure.ac
parentf6bdc4c133a26084e3a4457ad8dcc27c56344bb5 (diff)
downloadgnunet-4f7742c31bcf64550dae6a14d6b6da54d6d57e59.tar.gz
gnunet-4f7742c31bcf64550dae6a14d6b6da54d6d57e59.zip
-fix for #688590: allow user to specify how to install nsslibs
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac36
1 files changed, 36 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c1d463a26..0bedbaca9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -812,6 +812,42 @@ AC_ARG_WITH(sudo,
812AC_SUBST(SUDO_BINARY) 812AC_SUBST(SUDO_BINARY)
813AM_CONDITIONAL([HAVE_SUDO], [test "x$SUDO_BINARY" != "x" -o -w /]) 813AM_CONDITIONAL([HAVE_SUDO], [test "x$SUDO_BINARY" != "x" -o -w /])
814 814
815
816# test for nssdir
817AC_MSG_CHECKING(with nssdir)
818AC_ARG_WITH(nssdir,
819 [ --with-nssdir=PATH where to install NSS plugins],
820 [AC_MSG_RESULT("$with_nssdir")
821 case $with_nssdir in
822 no)
823 NSS_DIR=
824 install_nss=0
825 ;;
826 yes)
827 NSS_DIR="/lib"
828 install_nss=1
829 ;;
830 *)
831 NSS_DIR=$with_nssdir
832 install_nss=1
833 ;;
834 esac
835 ],
836 [
837 if test "x$SUDO_BINARY" != "x" -o -w /
838 then
839 NSS_DIR="/lib"
840 install_nss=1
841 AC_MSG_RESULT([yes, to /lib])
842 else
843 NSS_DIR=
844 install_nss=0
845 AC_MSG_RESULT([no])
846 fi
847 ])
848AC_SUBST(NSS_DIR)
849AM_CONDITIONAL([INSTALL_NSS], [test "x$install_nss" != "x0"])
850
815# test for gnunetdns group name 851# test for gnunetdns group name
816GNUNETDNS_GROUP=gnunetdns 852GNUNETDNS_GROUP=gnunetdns
817AC_MSG_CHECKING(for gnunetdns group name) 853AC_MSG_CHECKING(for gnunetdns group name)