aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2016-09-16 11:55:15 +0000
committerChristian Grothoff <christian@grothoff.org>2016-09-16 11:55:15 +0000
commit56ba7fb37960428cb758d0dad7e0e1b423fe86f6 (patch)
tree195b5beeb1340497127dcb7536bbc65edc56bd21 /configure.ac
parente268822d23cb12d7748c2f326b18e3fa7daceca6 (diff)
downloadgnunet-56ba7fb37960428cb758d0dad7e0e1b423fe86f6.tar.gz
gnunet-56ba7fb37960428cb758d0dad7e0e1b423fe86f6.zip
fix #4653
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 16 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 79cfa2ec2..af0e9306d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -826,11 +826,19 @@ SAVE_CPPFLAGS=$CPPFLAGS
826AC_MSG_CHECKING(for mysql) 826AC_MSG_CHECKING(for mysql)
827AC_ARG_WITH(mysql, 827AC_ARG_WITH(mysql,
828 [ --with-mysql=PFX base of MySQL installation], 828 [ --with-mysql=PFX base of MySQL installation],
829 [AC_MSG_RESULT("$with_mysql") 829 [AC_MSG_RESULT([$with_mysql])
830 if test "$with_mysql" != "no" 830 case $with_mysql in
831 then 831 no)
832 if test "$with_mysql" != "yes" 832 ;;
833 then 833 yes|"")
834 AC_CHECK_HEADERS(mysql/mysql.h,
835 AC_CHECK_LIB(mysqlclient, mysql_init,
836 MYSQL_LDFLAGS="-L$with_mysql/lib -L$with_mysql/lib/mysql"
837 MYSQL_CPPFLAGS="-I$with_mysql/include"
838
839 mysql=true), [], [$CYGWIN_MYSQL_MAGIC])
840 ;;
841 *)
834 LDFLAGS="-L$with_mysql/lib -L$with_mysql/lib/mysql $LDFLAGS $ZLIBS" 842 LDFLAGS="-L$with_mysql/lib -L$with_mysql/lib/mysql $LDFLAGS $ZLIBS"
835 CPPFLAGS="-I$with_mysql/include $CPPFLAGS" 843 CPPFLAGS="-I$with_mysql/include $CPPFLAGS"
836 AC_CHECK_HEADERS(mysql/mysql.h, 844 AC_CHECK_HEADERS(mysql/mysql.h,
@@ -839,8 +847,8 @@ AC_ARG_WITH(mysql,
839 MYSQL_CPPFLAGS="-I$with_mysql/include" 847 MYSQL_CPPFLAGS="-I$with_mysql/include"
840 848
841 mysql=true), [], [$CYGWIN_MYSQL_MAGIC]) 849 mysql=true), [], [$CYGWIN_MYSQL_MAGIC])
842 fi 850 ;;
843 fi 851 esac
844 ], 852 ],
845 [AC_MSG_RESULT([--with-mysql not specified]) 853 [AC_MSG_RESULT([--with-mysql not specified])
846 if test -d "/usr/lib64/mysql"; then 854 if test -d "/usr/lib64/mysql"; then
@@ -906,7 +914,7 @@ AC_ARG_WITH(microhttpd,
906 case $with_microhttpd in 914 case $with_microhttpd in
907 no) 915 no)
908 ;; 916 ;;
909 yes) 917 yes|"")
910 AC_CHECK_HEADERS([microhttpd.h], 918 AC_CHECK_HEADERS([microhttpd.h],
911 AC_CHECK_DECL(MHD_OPTION_PER_IP_CONNECTION_LIMIT, 919 AC_CHECK_DECL(MHD_OPTION_PER_IP_CONNECTION_LIMIT,
912 AC_CHECK_LIB([microhttpd], [MHD_get_fdset2], 920 AC_CHECK_LIB([microhttpd], [MHD_get_fdset2],