aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSree Harsha Totakura <totakura@in.tum.de>2013-05-08 09:52:40 +0000
committerSree Harsha Totakura <totakura@in.tum.de>2013-05-08 09:52:40 +0000
commit5c466f88da9a8f1fb6f247ec2c9972db53fa5bc0 (patch)
tree3c51046017229c734133b58b2593f8e7723bdce9 /configure.ac
parent063b0e3813bcb504e24de51f91e47c6836a413ad (diff)
downloadgnunet-5c466f88da9a8f1fb6f247ec2c9972db53fa5bc0.tar.gz
gnunet-5c466f88da9a8f1fb6f247ec2c9972db53fa5bc0.zip
- generate histograms based on configure option --enable-nse-histogram
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 21 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8a6fb3a7d..1a760b64f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -967,6 +967,27 @@ AC_MSG_RESULT($enable_ll)
967AM_CONDITIONAL([ENABLE_LL], [test "x$ll" = "x1"]) 967AM_CONDITIONAL([ENABLE_LL], [test "x$ll" = "x1"])
968AC_DEFINE_UNQUOTED([ENABLE_LL], [$ll], [Build with LL support]) 968AC_DEFINE_UNQUOTED([ENABLE_LL], [$ll], [Build with LL support])
969 969
970# Check if NSE has to send timestamp information to testbed logger for
971# generating histogram of messages received
972AC_MSG_CHECKING(if NSE has to send timestamp information to testbed logger)
973AC_ARG_ENABLE([nse-histogram],
974 [AS_HELP_STRING([--enable-nse-histogram],
975 [have NSE send timestamp information to testbed logger for generating
976 histogram of received messages. NOT useful for production (default is
977 NO)])],
978 [if test "x$enableval" = "xno"
979 then
980 nse_histogram=0
981 else
982 nse_histogram=1
983 fi],
984 [nse_histogram=0
985 enable_nse_histogram=no])
986AC_MSG_RESULT($enable_nse_histogram)
987AM_CONDITIONAL([ENABLE_NSE_HISTOGRAM], [test "x$nse_histogram" = "x1"])
988AC_DEFINE_UNQUOTED([ENABLE_NSE_HISTOGRAM], [$nse_histogram],
989 [have NSE send timestamp information to testbed logger])
990
970# should 'make check' run tests? 991# should 'make check' run tests?
971AC_MSG_CHECKING(whether to run tests) 992AC_MSG_CHECKING(whether to run tests)
972AC_ARG_ENABLE([testruns], 993AC_ARG_ENABLE([testruns],