aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLRN <lrn1986@gmail.com>2014-01-08 14:14:44 +0000
committerLRN <lrn1986@gmail.com>2014-01-08 14:14:44 +0000
commit73bbb9dfcfaa75720f90d35f4f9e9bf731ea9bc5 (patch)
tree3e6090b210a75efeaae2e624abfe53a71230ca64 /configure.ac
parent39d0485fb4ec8cb5b3142c86130b276ed455cb65 (diff)
downloadgnunet-73bbb9dfcfaa75720f90d35f4f9e9bf731ea9bc5.tar.gz
gnunet-73bbb9dfcfaa75720f90d35f4f9e9bf731ea9bc5.zip
Add GStreamer-based implementation of conversation helpers
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac58
1 files changed, 44 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index a9ba0125c..7aea4d12e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -388,10 +388,7 @@ AC_CHECK_LIB(pulse,pa_stream_peek,
388 [AC_CHECK_HEADER([pulse/simple.h],pulse=1)]) 388 [AC_CHECK_HEADER([pulse/simple.h],pulse=1)])
389if test "$pulse" = 1 389if test "$pulse" = 1
390then 390then
391 AM_CONDITIONAL(HAVE_PULSE, true)
392 AC_DEFINE([HAVE_PULSE],[1],[Have libpulse(audio) library]) 391 AC_DEFINE([HAVE_PULSE],[1],[Have libpulse(audio) library])
393else
394 AM_CONDITIONAL(HAVE_PULSE, false)
395fi 392fi
396if test "$build_target" = "mingw" 393if test "$build_target" = "mingw"
397then 394then
@@ -404,12 +401,39 @@ AC_CHECK_LIB(opus,opus_decode_float,
404 [AC_CHECK_HEADER([opus/opus.h],opus=1)]) 401 [AC_CHECK_HEADER([opus/opus.h],opus=1)])
405if test "$opus" = 1 402if test "$opus" = 1
406then 403then
407 AM_CONDITIONAL(HAVE_OPUS, true)
408 AC_DEFINE([HAVE_OPUS],[1],[Have libopus library]) 404 AC_DEFINE([HAVE_OPUS],[1],[Have libopus library])
409else
410 AM_CONDITIONAL(HAVE_OPUS, false)
411fi 405fi
412 406
407gst=0
408PKG_CHECK_MODULES(
409 [GST],
410 [glib-2.0 gobject-2.0 gstreamer-1.0 gstreamer-app-1.0 gstreamer-audio-1.0],
411 [
412 gst=1
413 AC_MSG_RESULT(ok)
414 ], [
415 gst=0
416 AC_MSG_RESULT(not found)
417 ])
418
419# Pulse Audio
420if test "x$pulse" != "x1" -o "x$opus" != "x1"
421then
422 if test "x$gst" != "x1" -o "x$opus" != "x1"
423 then
424 conversation_backend=none
425 AM_CONDITIONAL(BUILD_PULSE_HELPERS, false)
426 AM_CONDITIONAL(BUILD_GST_HELPERS, false)
427 else
428 conversation_backend=gst
429 AM_CONDITIONAL(BUILD_PULSE_HELPERS, false)
430 AM_CONDITIONAL(BUILD_GST_HELPERS, true)
431 fi
432else
433 conversation_backend=pulse
434 AM_CONDITIONAL(BUILD_PULSE_HELPERS, true)
435 AM_CONDITIONAL(BUILD_GST_HELPERS, false)
436fi
413 437
414# libgnurl 438# libgnurl
415LIBGNURL_CHECK_CONFIG(,7.34.0,gnurl=1,gnurl=0) 439LIBGNURL_CHECK_CONFIG(,7.34.0,gnurl=1,gnurl=0)
@@ -1519,17 +1543,23 @@ then
1519 AC_MSG_NOTICE([NOTICE: libmicrohttpd not found, http transport will not be installed.]) 1543 AC_MSG_NOTICE([NOTICE: libmicrohttpd not found, http transport will not be installed.])
1520fi 1544fi
1521 1545
1522# Pulse Audio 1546# conversation
1523if test "x$pulse" != "x1" 1547if test "x$conversation_backend" == "xnone"
1524then 1548then
1525 AC_MSG_NOTICE([NOTICE: libpulse(audio) not found, conversation will not be built.]) 1549 if test "x$pulse" != "x1"
1550 then
1551 AC_MSG_NOTICE([NOTICE: libpulse(audio) not found, conversation will not be built.])
1552 fi
1553 if test "x$opus" != "x1"
1554 then
1555 AC_MSG_NOTICE([NOTICE: libopus not found, conversation will not be built.])
1556 fi
1557 if test "x$gst" != "x1"
1558 then
1559 AC_MSG_NOTICE([NOTICE: GStreamer not found, conversation will not be built.])
1560 fi
1526fi 1561fi
1527 1562
1528# Opus
1529if test "x$opus" != "x1"
1530then
1531 AC_MSG_NOTICE([NOTICE: libopus not found, conversation will not be built.])
1532fi
1533 1563
1534AC_MSG_NOTICE([NOTICE: Database support is set to MySQL: $mysql, SQLite: $sqlite, Postgres: $postgres]) 1564AC_MSG_NOTICE([NOTICE: Database support is set to MySQL: $mysql, SQLite: $sqlite, Postgres: $postgres])
1535 1565