aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2012-10-23 18:42:46 +0000
committerChristian Grothoff <christian@grothoff.org>2012-10-23 18:42:46 +0000
commit798b1b3431ccf345a93bd01413a64d272e530c6c (patch)
tree2aee80048c9615a438fe362f79a8fb5c3b22eeee /configure.ac
parenta25686672d1ca40a856292ee65f45e0e736a7a8f (diff)
downloadgnunet-798b1b3431ccf345a93bd01413a64d272e530c6c.tar.gz
gnunet-798b1b3431ccf345a93bd01413a64d272e530c6c.zip
-add option to make expensive heap stat gathering optional
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 28a23f8f0..3caaf253a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -999,6 +999,15 @@ AC_ARG_ENABLE([experimental],
999AC_MSG_RESULT($enable_experimental) 999AC_MSG_RESULT($enable_experimental)
1000AM_CONDITIONAL([HAVE_EXPERIMENTAL], [test "x$enable_experimental" = "xyes"]) 1000AM_CONDITIONAL([HAVE_EXPERIMENTAL], [test "x$enable_experimental" = "xyes"])
1001 1001
1002# should memory statistics be kept (very expensive CPU-wise!)
1003AC_MSG_CHECKING(whether to create expensive statistics on memory use)
1004AC_ARG_ENABLE([heapstats],
1005 [AS_HELP_STRING([--enable-heapstats], [enable expensive heap statistics])],
1006 [enable_heapstats=1],
1007 [enable_heapstats=0])
1008AC_MSG_RESULT($enable_heapstats)
1009AC_DEFINE_UNQUOTED([ENABLE_HEAP_STATISTICS],$enable_heapstats,[enable expensive heap statistics])
1010
1002# should code be enabled that works around missing OS functionality on Windows? 1011# should code be enabled that works around missing OS functionality on Windows?
1003# used for test cases 1012# used for test cases
1004if test $build_target = "mingw" 1013if test $build_target = "mingw"