aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMartin Schanzenbach <schanzen@gnunet.org>2021-12-13 17:37:16 +0100
committerMartin Schanzenbach <schanzen@gnunet.org>2021-12-13 17:37:16 +0100
commit7a6ee6fc7c7f7e77f6b9b2612cb96c0ccea0da03 (patch)
treef665e53267fd29886abd938d94d2c86d4dc5c2a8 /configure.ac
parent8e94bfad642ed73732f052a9fb51892fb32fa2e3 (diff)
downloadgnunet-7a6ee6fc7c7f7e77f6b9b2612cb96c0ccea0da03.tar.gz
gnunet-7a6ee6fc7c7f7e77f6b9b2612cb96c0ccea0da03.zip
- fix experimental flag
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 7 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 1e5ba403f..870518862 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1232,9 +1232,11 @@ AC_SUBST([JAVAPORT])
1232AC_ARG_ENABLE([experimental], 1232AC_ARG_ENABLE([experimental],
1233 [AS_HELP_STRING([--enable-experimental], 1233 [AS_HELP_STRING([--enable-experimental],
1234 [enable experimental code paths (default is no)])], 1234 [enable experimental code paths (default is no)])],
1235 [enable_experimental="${enableval}"] 1235 [AS_IF([test "x$enableval" = "xno"],
1236 [enable_experimental="no"]) 1236 [enable_experimental=0],
1237AM_CONDITIONAL([HAVE_EXPERIMENTAL], [test "x$enable_experimental" = "xyes"]) 1237 [enable_experimental=1])],
1238 [enable_experimental=0])
1239AM_CONDITIONAL([HAVE_EXPERIMENTAL], [test "x$enable_experimental" = "x1"])
1238 1240
1239# check if malicious code should be compiled (for testing) 1241# check if malicious code should be compiled (for testing)
1240AC_ARG_ENABLE([malicious], 1242AC_ARG_ENABLE([malicious],
@@ -1489,13 +1491,13 @@ AS_IF([test "x$enable_java_ports" = "xyes"],
1489 [java_msg="no"]) 1491 [java_msg="no"])
1490 1492
1491# experimental code is enabled 1493# experimental code is enabled
1492AS_IF([test "x$enable_experimental" = "xyes"], 1494AS_IF([test "x$enable_experimental" = "x1"],
1493 [experimental_msg="yes"], 1495 [experimental_msg="yes"],
1494 [experimental_msg="no"]) 1496 [experimental_msg="no"])
1495 1497
1496# experimental code for transport is enabled 1498# experimental code for transport is enabled
1497transport_msg="tcp udp unix http" 1499transport_msg="tcp udp unix http"
1498AS_IF([test "x$build_target" = "xlinux" && test "x$enable_experimental" = "xyes"], 1500AS_IF([test "x$build_target" = "xlinux" && test "x$enable_experimental" = "x1"],
1499 [transport_msg="tcp udp unix http wlan"]) 1501 [transport_msg="tcp udp unix http wlan"])
1500 1502
1501# libidn version 1503# libidn version